patrickm
Participant
Post count: 171

[quote=98032]

bump; added 5x scale scanline overlay (1920×1080). Also added step-by-step instructions.

How do I make the changes permanent. I try to go back on the RGUI and hit on the save new config option and nothing happens. Once I restart the emulator it goes back to the old settings.
By mistake I change on the RGUI the configurations to the retroarch.cfg file is that ok? How do I change back to the old libreto field

You can make settings stick by navigating to the right config file in /opt/retropie/configs/ and find the right emulator folder. Within each emulator folder there is a “retroarch.cfg” which has settings which overwrite the global settings. Any settings which you wish to make permanent should be added there. There should also be an “emulator-name.cfg” in each emulator folder. You can rename this to “retroarch.cfg” and it will be loaded next time you launch RA.

well yeah I know how to do that. I set a permanent shader for my snes emulator. What I want to know is that why when I follow your steps I save it in the RGUI and once I exit out of any particular emulator my previous settings of adding the scanlines, filters and scaling are erase. Once I start the emulator again I have to go and go through your steps once again. Do you happen to know the code that I have to write in the retroarch.cfg file to make the steps from your original post permanent for my nes, snes, and megadrive. Also when I apply your scanline file on the RGUI I don’t see a difference on the nes or snes emulator. Also how do you apply the dotmask filter plus the scanline file that you provided together. If I go to options and filters I don’t see that particular filter. All your help is appreciated, thanks.

[/quote]

To set the overlay, put the .png and .cfg (for the overlay) in the appropriate overlay folder, then select the .cfg in retroarch. Settings -> overlay settings, set the overlay preset and be sure “overlay enable” is on

To set the shader go to options -> shader options -> shader passes, set to 1. Then under shader 0 select the dotmask shader in the /shader/CRT/ directory. The hit apply shader settings.

Make sure SNES and NES are set to render at the correct resolution, also. Scaling can cause overlays to not work correctly. Also make sure overlay opacity is set higher than 0 :)