Post count: 139

Thanks, Buzz. I compiled a new version of the Intellivision, jzintv, which fixed a bug that was breaking keyboard hacks. The SVN source is available at the following link: http://spatula-city.org/~im14u2c/intv/dl/jzintv-svn-20141028.zip.

On exit from jzintv, I get a black screen and the pi is completely unresponsive. I can SSH into the pi but sudo reboot doesn’t work. The only way to reset the pi is through a power cycle. There is a long-running issue at the ES github (../EmulationStation/issues/206) that suggests that it’s affecting other non-Retroarch emulators such as VICE.

There is a fix at this post – ../emulationstation-not-restarting-on-emulator-exit/#post-81307. I tried to write a script that would replicate this but I can’t seem to get the exit command in step 2 working as it’s an inbuilt command. Also, I’m not entirely sure why typing exit should relaunch ES.

I also followed this thread ../atari-2600-stella-locks-up-after-exit/ which described a similar situation to mine. I have tried to enable dispmanx for jzintv. I installed dispmanx from the (updated) Retropie setup script and then enabled it for jzintv, also from the setup script. I am still getting a black screen on exit. Now I’m not sure whether dispmanx doesn’t solve the issue for jzintv or whether dispmanx wasn’t enabled as I had compiled jzintv from an alternative source to the Retropie script.

Any advice would be appreciated.