So I did some more playing around – it would seem the 1.10 SD image is messed up in some way. When I simply tried to run ‘xboxdrv’, I got an error that indicated that something was conflicting – it told me to run ‘rmmod xpad’. After doing that and manually running xboxdrv, the controller tagged up properly. Even with doing that, I could not get the service to start. Upon reboot, it would seem ‘xpad’ was starting and preventing xboxdrv from starting as it went back to all four LEDs flashing. And worse than that, when I tried to boot RetroPie with my powered USB hub attached, it crashed every boot – without it, it boots fine. Hub works fine with Rasbian.

I then re-imaged the card with stock Raspian, installed xboxdrv, configured the service and config file specified in method 3 and…. It Worked!

The way I read it, using method 1, the controller(s) must be on before you boot the RPi. With method 3, you can turn the controller on after it’s booted and it’ll tag up.

I might be biting off more than I can chew here, but I then got the ‘retropie setup script’ and currently have it running an install… We’ll see if it still works after installing RetroPie…

Edit: Well, that was a fail. It ‘completed’ the install, but when I try to run emulationstation, I get an error indicating it can’t load the shared library ‘libboost_system.so.1.49.0’ :(