Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Volans
    Participant
    Post count: 7

    Off topic: I don’t see a way to delete already posted things. Here it is:

    Edit your post and add this line without spaces ;) –>

    a s s e t s _ d i r e c t o r y = / o p t / r e t r o p i e / e m u l a t o r s / r e t r o a r c h / a s s e t s

    A good way to raise the post count for an account without flooding. Sometimes I think bugs are magically attracted by me :D

    Volans
    Participant
    Post count: 7

    I made a backup of my retroarch.cfg and deleted all out commented lines:

    core_options_path = /opt/retropie/configs/all/retroarch-core-options.cfg
    The post deleting line of death” :D
    system_directory = /home/pi/RetroPie/BIOS
    config_save_on_exit = false
    video_fullscreen = true
    video_threaded = true
    video_smooth = false
    video_aspect_ratio = 1.77
    video_aspect_ratio_auto = false
    video_shader_enable = true

    video_shader_dir = /opt/retropie/emulators/retroarch/shader/
    overlay_directory = /opt/retropie/emulators/retroarch/overlays
    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/retroarch/configs/

    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down

    input_exit_emulator = escape
    input_shader_next = m
    input_shader_prev = n
    input_rewind = r
    rewind_enable = false
    rewind_buffer_size = 10
    rewind_granularity = 2
    video_gpu_screenshot = true

    input_enable_hotkey = alt
    input_exit_emulator_btn = “6”
    input_menu_toggle = F1

    input_player1_joypad_index = “0”
    input_player1_b_btn = “0”
    input_player1_y_btn = “2”
    input_player1_select_btn = “6”
    input_player1_start_btn = “7”
    input_player1_up_btn = “13”
    input_player1_down_btn = “14”
    input_player1_left_btn = “11”
    input_player1_right_btn = “12”
    input_player1_a_btn = “1”
    input_player1_x_btn = “3”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_axis = “+2”
    input_player1_r2_axis = “+5”
    input_player1_l3_btn = “9”
    input_player1_r3_btn = “10”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+3”
    input_player1_r_x_minus_axis = “-3”
    input_player1_r_y_plus_axis = “+4”
    input_player1_r_y_minus_axis = “-4”

    All lines added or changed by me are bolt.

    Volans
    Participant
    Post count: 7

    Yes, I know ;) This line was by default at the end of ‘/opt/retropie/configs/all/retroarch.cfg’. > “input_enable_hotkey_btn = nul
    After I changed the hotkey behaviour: ‘/home/pi/RetroPie-Setup/retropie_setup.sh’ > “Configuration” > “Change hotkey behaviour” > “Press ALT to enable hotkeys.”, this line changed into “input_enable_hotkey_btn = alt” and “input_menu_toggle = F1” was added.

    In my last post I listed the behaviour in every emulator I want to use twice. One time with “Hotkeys enabled (default)” and the other time with “Press ALT to enable hotkeys”. The best result I had with the second option: I was able to open RGUI with ALT+F1, switch shaders with ALT+M/N and exit the emulator with ALT+ESC. But only in SNES and Playstation emulator. In N64 emulator only ALT+ESC for exiting works.. nothing more. Even the button (btn#6; SELECT) doesn’t work. And if I try to use left analog stick (btn#9) for exiting the emulator it doesn’t work at all.. SNES, N64, PS. :/

    Volans
    Participant
    Post count: 7

    Test: I posted something, then I wanted to add/edit something and now the post is gone. O.o

    Volans
    Participant
    Post count: 7

    Thank you, but I already saw this video. It’s very good.. but he explains how they should behave.

    After some hours trying to solve the problem by editing the configs, I decided to begin from scratch. This time with a Raspian image and RetroPie compiled from sources. After that I configured my XBOX360 controller:

    input_player1_joypad_index = "0"
    input_player1_b_btn = "0"
    input_player1_y_btn = "2"
    input_player1_select_btn = "6"
    input_player1_start_btn = "7"
    input_player1_up_btn = "13"
    input_player1_down_btn = "14"
    input_player1_left_btn = "11"
    input_player1_right_btn = "12"
    input_player1_a_btn = "1"
    input_player1_x_btn = "3"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_axis = "+2"
    input_player1_r2_axis = "+5"
    input_player1_l3_btn = "9"
    input_player1_r3_btn = "10"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+3"
    input_player1_r_x_minus_axis = "-3"
    input_player1_r_y_plus_axis = "+4"
    input_player1_r_y_minus_axis = "-4"

    ..and added input_exit_emulator_btn = “6”, because I want to be able to stop the emulator via controller. Then, without changing any hotkey behaviour, the follwing works (not):

    SNES:
    Exiting via ESC doesn’t work
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) works

    Playstation:
    Exiting via ESC doesn’t work
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) works

    N64:
    Exiting via ESC works
    RGUI via F1 doesn’t work
    Switching shaders via M&N doesn’t work
    Exiting via SELECT (btn#6) doesn’t work

    Then I changed the hotkey behaviour to “Press ALT to enabled hotkeys“:

    SNES:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 works
    Switching shaders via ALT+M&N works
    Exiting via SELECT (btn#6) works

    Playstation:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 works
    Switching shaders via ALT+M&N works
    Exiting via SELECT (btn#6) works

    N64:
    Exiting via ALT+ESC works
    RGUI via ALT+F1 doesn’t work
    Switching shaders via ALT+M&N doesn’t work
    Exiting via SELECT (btn#6) doesn’t

    I’m really confused. :/ I didn’t change any other configs..

    ..just for fun I tested input_exit_emulator_btn = “9” to have the analog stick for exiting the emulators: It doesn’t work in SNES, N64 and Playstation. :(

    PS: After compiling I had to run this command, because some directories were owned by root. Is this normal?

    sudo chown -hR pi:pi /home/pi/

    I hope somebody can help me..

    Volans
    Participant
    Post count: 7

    I’m only able to open RGUI if I run the retroarch binary with “–menu”. :/

Viewing 6 posts - 1 through 6 (of 6 total)