Forum Replies Created

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • shakz
    Participant
    Post count: 2
    in reply to: Image too big #122100

    I think there are a couple things you can try.
    You will need to edit your /boot/config.txt file
    The default settings are as follows.

    # uncomment if hdmi display is not detected and composite is being output
    #hdmi_force_hotplug=1
    
    # uncomment to force a specific HDMI mode (this will force VGA)
    #hdmi_group=1
    #hdmi_mode=1
    

    It sounds like you may need to uncomment force_hotplug. If you dont know how to use vi or edit files in linux just run this.
    sudo perl -p -i -e 's/#hdmi_force_hotplug=1/hdmi_force_hotplug=1/g' /boot/config.txt
    That just turns this.
    #hdmi_force_hotplug=1
    into this
    hdmi_force_hotplug=1
    so the pie will read it after bootup.
    Reboot and see if this works.
    If not reverse it running the following command.
    sudo perl -p -i -e 's/hdmi_force_hotplug=1/#hdmi_force_hotplug=1/g' /boot/config.txt

    Next you can try forcing the pie into 1080p mode. With the following commands. Again they are just uncommenting the variables so your machine will read them on the next boot.
    Not sure where you are from so here are the NA and EU setups.

    for NTSC (North American TVs 60Hz)
    1080p

    sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=16/g' /boot/config.txt

    to switch back tp default from NTSC settings.

    sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/hdmi_mode=16/#hdmi_mode=1/g' /boot/config.txt

    for PAL (European TVs 50Hz)

    sudo perl -p -i -e 's/#hdmi_group=1/hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/#hdmi_mode=1/hdmi_mode=31/g' /boot/config.txt

    To go back to default from pal settings

    sudo perl -p -i -e 's/hdmi_group=1/#hdmi_group=1/g' /boot/config.txt
    sudo perl -p -i -e 's/hdmi_mode=31/#hdmi_mode=1/g' /boot/config.txt

    You can see the values here.
    https://www.raspberrypi.org/documentation/configuration/config-txt.md

    Hope this helps you!

    shakz
    Participant
    Post count: 2

    Howdy Chris,
    Just a quick tip. I have the same model pi. With default settings NES games sound would stutter. SNES lagged. You can test yourself and see. My issues went away when I used the raspi-config script to overclock the pi to 1ghz or 10000. I think its called turbo or something. You will need a heatsink or fan though to keep the pi running smooth.
    Hope this helps!

Viewing 2 posts - 1 through 2 (of 2 total)