Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • NoFlo
    Participant
    Post count: 9

    Here is the content of the config file as well as the output of jstest with and without a gamepad connected.

    controlblockconfig
    pi@pisnes:~ $ cat /etc/controlblockconfig.cfg
    {
    “input” : {
    //”gamepadtype” : “arcade”
    // “gamepadtype” : “mame”
    “gamepadtype” : “snes”
    // “gamepadtype” : “none”
    },
    “powerswitch” : {
    “activated” : true
    // “activated” : false
    }

    }

    js0 (gamepad connected)
    pi@pisnes:~ $ jstest /dev/input/js0
    Driver version is 2.1.0.
    Joystick (ControlBlock SNES Gamepad) has 2 axes (X, Y)
    and 8 buttons (BtnX, BtnY, BtnTL, BtnTR, BtnTR2, BtnSelect, BtnThumbL, BtnThumbR).
    Testing … (interrupt to exit)
    Axes: 0:-32767 1:-32767 Buttons: 0:on 1:on 2:on 3:on 4:on 5:on 6:on 7:on

    js1 (no gamepad connected)
    pi@pisnes:~ $ jstest /dev/input/js1
    Driver version is 2.1.0.
    Joystick (ControlBlock SNES Gamepad) has 2 axes (X, Y)
    and 8 buttons (BtnX, BtnY, BtnTL, BtnTR, BtnTR2, BtnSelect, BtnThumbL, BtnThumbR).
    Testing … (interrupt to exit)
    Axes: 0:-32767 1:-32767 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7:off

    NoFlo
    Participant
    Post count: 9

    I am having the same problem for a while.
    Today, I decided to try it again, but still no luck.
    As described in the below linked, rather old thread, I tried to switch all components but got no working system. jstest still showing on for all buttons…

    NoFlo
    Participant
    Post count: 9

    Unfortunately, I am still unable to use my controllers. I have no idea what else I can try to solve the problem. In jstest all of my controller buttons are shown “off” with no controller connected and stay “on” after connecting. To isolate the problem I swapped the following parts:
    – power supply
    – raspberry pi (two different Pi 2 B)
    – controlblock (got a second one, pre-soldered, just in case…)
    – wiring of the controller
    – snes controller
    – micro sd card
    – installaton of retropie (both stable and beta release)
    – overclocking

    Any ideas? Anything I forgot to check? I am clueless… :(

    NoFlo
    Participant
    Post count: 9

    As mentioned before, overclocking is not the problem in my (and OP’s?) case.
    Even with the new version, the controller is not working (showing “off” when disconnected, “on” when connected) on both controller ports. If set to arcade controller, all buttons are working correctly when connected to GND.
    Any other ideas?

    NoFlo
    Participant
    Post count: 9

    [quote=94825] @NoFlo: I still didn’t get it working. I’ll try reinstalling and reconfiguring RetroPie and see if it works then.[/quote]
    For me, this did not work. Installed Retropie on another SD Card to make sure the problems are not related to the current installation but it did not change anything.
    Also, I tried version 2.6 and version 3 BETA with no success.

    I am curious about your experiences with a fresh installation :)

    NoFlo
    Participant
    Post count: 9

    Unfortunately the overclocking settings do not affect the behaviour. At all settings, the buttons are “off” with no controller connected, and “on” with a connected controller.
    I also tried to use another power supply, but that did not help either.

    Attached are a few pictures of my setup. The wires are all black, but I checked the wiring many times and the controller pins are connected as documented.
    Even though the Controller Pins are soldered on the circuit board, I ensured that there are no connections between the pins and they are all isolated from the remaining parts.

    As mentioned before, when switching the controller type to arcade, all buttons are working (“on” when connected to GND, “off” when not)

    Edit: @dotarj did you find a solution?

    NoFlo
    Participant
    Post count: 9

    Thank you for your information regarding the VCC and GNC connection.

    Unfortunately, even after switching those two I cannot get the SNES controller to work. The strange behaviour when overclocking is solved, but the following persists:

    – With the controlblockconfig setting SNES, jstest shows all buttons as “off” if no controller is connected. After connceting a controller, all of the buttons switch to the “on” state and stay “on”.

    I have no idea, what I could do to solve this problem. Maybe you can tell me something, I can try…

    jstest output with no controller connected:

    Driver version is 2.1.0.
    Joystick (ControlBlock SNES Gamepad) has 2 axes (X, Y)
    and 8 buttons (BtnX, BtnY, BtnTL, BtnTR, BtnTR2, BtnSelect, BtnThumbL, BtnThumbR).
    Testing … (interrupt to exit)
    Axes: 0: 0 1: 0 Buttons: 0:off 1:off 2:off 3:off 4:off 5:off 6:off 7:off

    jstest output with controller connected:

    Driver version is 2.1.0.
    Joystick (ControlBlock SNES Gamepad) has 2 axes (X, Y)
    and 8 buttons (BtnX, BtnY, BtnTL, BtnTR, BtnTR2, BtnSelect, BtnThumbL, BtnThumbR).
    Testing … (interrupt to exit)
    Axes: 0:-32767 1:-32767 Buttons: 0:on 1:on 2:on 3:on 4:on 5:on 6:on 7:on

    NoFlo
    Participant
    Post count: 9

    some (maybe useful) information I collected @petrockblog, using a Raspberry Pi 2 B

    – The wiring in your guide shows another pin setup of the SNES controller as anywhere else (switched 5V/VCC and Ground) – inadvertently or intentionally?

    – All the connections are working (tested as “arcade controller” with jstest as described above)

    – With the controlblockconfig setting SNES, jstest shows all buttons as “off” if no controller is connected. After connceting a controller, all of the buttons switch to the “on” state and stay “on”.

    – When overclocking (“Pi2” setting), the abovementioned behaviour changes and all buttons are shown as “on”, no matter if a controller is connected or not.

    any ideas?

    NoFlo
    Participant
    Post count: 9

    Same problem here. Any new information / ideas regarding this?

Viewing 9 posts - 1 through 9 (of 9 total)