Forum Replies Created

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • chyczewski
    Participant
    Post count: 13

    [quote=87729]Thats true hcitool will not work, but hciconfig will.

    I am still not able to connect more than two controllers at a time, as least wireless. I have four controllers each of them will establish connection, if not two already connected.
    Where does sixad write logs?
    [/quote]

    Not sure where the logs go. I just tested 3 PS3 controllers working fine. All of you controllers are paired? meaning you can get all of them to connect to retropie one at a time? You can get two at the same time at the most?

    Have you ran an updated retropie_setup.sh and installed ps3 controller (from the setup script)?

    after pairing 2 controllers when you run hciconfig what does it return?

    Thanks

    chyczewski
    Participant
    Post count: 13

    FIXED!

    If anyone is interested, to bypass the welcome, no gampad detected screen even with no controllers connected this is what I did to make it work everytime:

    plug in a USB keyboard and setup the buttons with the keyboard ONCE. Unplug keyboard and reboot. Should go straight to the main emulator menu.

    Thanks

    chyczewski
    Participant
    Post count: 13

    [quote=87380]I have come up with a very easy way to fix the multiple PS3 controller connecting issue.

    It turns out the mode PISCAN which turns on ISCAN and PSCAN at the same time for the bluetooth fixes the issue. The command to manually do this is

    “sudo hcitool hci0 piscan”

    This will let both controllers connect perfectly. So the easy fix I did was just above the Exit 0 in the /etc/rc.local file I added a line that reads:

    “hcitool hci0 piscan”

    So when the PI boots it enables that mode automatically with a nice simple command.

    The other thing I have noticed is that for some reason when you first copy the 2.5 image to your card and boot it your bluetooth adapter is in the state down. This is easily fixed with

    “sudo hciconfig hci0 up”

    Once you do this a single time there is a line in the /etc/blueooth/main.conf that tells your PI to remember the last manual state set on the adapter so it will be automatically up the next time you boot it.

    As for the controller not detected screen if you do not get the controllers paired fast enough the quick and dirty work around is to add a sleep 10 or so timer so there is a delay, you could also echo something like “press the PS button now to pair your controllers” which would make this make a little more sense.

    I would love to find a way to get rid of that splash page all together but I may be ok at bashing my way through issues with the help of Google and a little smarts but I am not a code monkey so I that is better left to the real smart people. Maybe an option?

    By the way do any of the core developers read these so they can implement these things into a bug fix? Now it will be straight forward now that we have figured it out. ;)
    [/quote]

    Good find.

    I did have in the older build bypass that damn gamepad screen at boot. Even with no controllers connected at the time it went straight to the main menu. I will try to work on that next to figure that out, maybe there is a solution out there, need to look into it.

    I just signed up to this forum couple days ago pertaining to the ps3 BT issue. I really hope the developers are reading or maybe there is a way to request a bug fix and share the solution. As far as I know this is the only thread with the solution to this issue as I was scratching my head before this solution for some time.

    Thanks to everyone for all your hard work. Love the RetroPie!

    chyczewski
    Participant
    Post count: 13

    [quote=87342]I tried Super Mario World and Donkey kong. Both stuttered wile running and jumping and fast images.

    I think it is because i have my resoltion to high. Its at 1920 x 1080 at the moment.

    Gonna try to fiddle with that first because last weewerkek before i got both controllers working i did not stutyer but i changed the resolution. Got to be that i think.

    Can you share your oppinion?
    [/quote]

    I agree it has to be something you processed with the resolution. I am using the regular snes emulator (not snes-pisnes or snes-snes9xrpi) and everything works great, even starfox on my rpi2.

    chyczewski
    Participant
    Post count: 13

    [quote=87331]OMG YES this works, you 2 guys are like gods to me.
    Thank you so much!!!

    Got 1 question though:
    I have my roms for the SNES in /home/pi/RetroPie/roms/snes
    This is the only snes emulator that the controllers work on, on the fly. But it is laggy sometimes (it stutters).

    I have the raspberry 2 B+. Set the memsplit to 256. How can i get the stuttering to stop?

    Please advice.
    [/quote]

    What game are you trying to play? I know a game like starfox will be a bit choppy, forget about Doom. If its every game then I would say its something with your settings. I played snes on both the original raspi B+ and the raspi 2 B+. Never had issues with more than a couple of games. You can open up retroarch config WHILE playing a game. On my controller it is Select and Triangle. You can also try select and R1. There are a few “hidden” keys to load state, save state, and one of them is to open config. Once you get retroarch config open, you can play with those settings.

    I can share my settings if need be, I did not change anything from default tho. Thanks!

    chyczewski
    Participant
    Post count: 13

    If you are starting fresh, I would download the latest retropie image and then run these commands as pi user:

    cd RetroPie-Setup
    sudo bash retropie_setup.sh

    That should open up the retropie screen then select:
    SETUP
    Install PS3 controller driver

    follow the on screen directions and you should be setup for the first controller. (It might complain that it cannot find the controller)

    REBOOT

    then run these commands as root:

    cd /opt/retropie/supplementary/ps3controller

    now plug in your first controller via usb and run:

    sudo ./sixpair

    this should set the MASTER for your controller to your Raspi BT dongle.

    now unplug the first controller and plug in the second controller and re-run:

    sudo ./sixpair

    same thing should happen.

    Modify the /usr/bin/emulationstation as described above and reboot

    should be golden

    chyczewski
    Participant
    Post count: 13

    Guys,

    playing around this morning with the hciconfig I think I might of came up with a solution.

    open up /usr/bin/emulationstation

    and enter this below the #!/bin/bash:

    sleep 2
    sudo hciconfig hci0 up
    sleep 1
    sudo hciconfig hci0 pscan
    sleep 13

    For some reason my hcicofig is coming up DOWN so i force it UP first, then force it to scan. A ton of reboots and its working like a champ so far.

    Let me know if this works for you guys as well.

    The only thing that bothers me is that if no controller is connected on reboot (I dont press the button right away) I get emulationstation complaining about no gamepad detected. Before didnt matter if no controllers were connected it would just launch to the main screen.

    P.S.
    Kasgore, I ran the old image I had with the old software, which i never had issues pairing to, the only thing was that the LEDs would all blink, but controllers were rock solid. Anyhow, running hciconfig showed me its was in PSCAN all the time back then. I think its safe to assume forcing it to PSCAN all the time should not affect anything negatively.

    chyczewski
    Participant
    Post count: 13

    Kasgore,

    Thats great news, I didn’t notice that before. Im wondering if we can run a script at boot up or some interval to force it into that mode.

    Thanks

    chyczewski
    Participant
    Post count: 13

    UPDATE:

    I was able to load an old image I had from several months ago and it works as it did before. Both controllers connect but the controller LEDs all blink non-stop. Functionally it is 100%

    I am pretty sure something with the apt-get update/upgrade, specifically with sixpair was changed. They fixed the profiles (LEDs get assigned) but this only works good with one controller. This needs to be fixed asap!

    When you run the script to install the ps3 controller from retropie-setup.sh it install a directory:

    /opt/retropie/supplementary/ps3controller

    In my old image this is not there, I have:

    /opt/retropie/supplementary/sixpair

    instead.

    I will do some more digging to see if I can make it work on the new image somehow. Maybe re-run the apt-get update/upgrade ONLY and see if that is what breaks it. But this will have to wait until I get some sleeeep.

    Thanks

    chyczewski
    Participant
    Post count: 13

    Yes I have tried that in the past before, not sure what that does and since it did not fix my two controller issue, i restored it to original.

    At this point, I have tried several different versions of the RetroPie software, two different types of BT dongles (BT211 and BT400) paired fine individually but cannot get both controllers online at the same time. I am out of ideas..

    chyczewski
    Participant
    Post count: 13

    Ok I can confirm that you can get both controller working MANUALLY by doing this:

    press PS button on the first controller and wait until its assigned P1.

    run:

    sudo sixad –stop
    sudo sixad –start

    and when it tells you to press the PS button press the PS button on controller 2, I had this working but by no means is this a solution.

    I imaged my SD card with the image I had that had the controllers working. They act the same way, which leads me to believe when we ran raspi-update it updated some firmware which is persistent no matter what version of RetroPie is used.

    I am using a asus USB-BT211 dongle

    thanks!

    chyczewski
    Participant
    Post count: 13

    Yes I can confirm both of my genuine PS3 controllers worked via bluetooth (all LEDs blinking but working)

    I was getting ready for rpi2 and used my retropie image and just ran all the updates to support RPI2 (which it works same as my regular rpi).

    I ran update/upgrade and rpi-update (fw?) and retropie-setup.sh script and updated binaries. Once done, I notice my LEDs were not blinking on the controller anymore and it was assigned a correct profile but for the life of me I cannot get both controllers to connect on boot.

    I did manage somehow to get both of them assigned via bluetooth ONCE. Worked beautifully but a simple reboot and they do not work again. Running sudo ./sixpar in combination is how I got them to both work somehow. I can try to re-create the situation to confirm.

    I also have an old SD card with the old retropie image before the updates I can try to pop in and see if the problem persists.

    chyczewski
    Participant
    Post count: 13

    Same issue here since I ran sudo apt-get update/upgrade

    Either controller connects with no issues as long as it is the first to do so. The second controller just blinks.

Viewing 13 posts - 1 through 13 (of 13 total)