Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • duckclimber
    Post count: 32

    I Recently built (almost finished) a tabletop arcade machine that uses a Raspberry Pi 2 as a hart and the Xin-Mo Dual Arcade USB-controller for my arcade buttons. But how much I try I can’t get the Xin-mo to work with two players. (And player 1 have “gamepad 2 and player 2 has “gamepad 1” when configured) (This is fixed, see below)

    My setup:
    *Raspberry Pi 2 running RetroPie 3.3.1
    *This USB Interface & standard Joystick set:–standard-joystick-set-109-p.asp

    I am not a newbie to RetroPie nor Linux and I have an other setup with a Raspberry Pi 1 running RetroPie hooked up with 4 controllers that works just fine.(MAME, SNES, NES, FBA, SMS, SMD and so on)

    First I tried putting usbhid.quirks=0x16c0:0x05e1:0x040 in the /boot/cmdline.txt and then RetroPie recognize Xin-mo as two joypads but the controllers interfere with each other.

    So I tried what almost every page links to when they have a problem with the Xin-Mo: and

    Didn’t get It to work, so I tried this:

    I have started to build my first Arcade machine based on retropie over the last few days. I was experiencing some issues with the Xin-mo controller but thanks to the efforts of people like “feederchain” in this thread I have everything up an running.

    My setup consists of the following;
    – Raspberry Pi B
    – Xin-mo dual arcade controller
    – 2 x joysticks and 16 buttons (Street Fighter II setup)
    – Retropie 3.2.1
    – Mame4All

    My config was working fine using a keyboard and Logitech F310 gamepad but when I added the Xin-mo and my custom joystick I couldn’t see it – this was resolved by installing custom_kernel_1.20150818-1.tar.gz referenced earlier in this thread.

    Next issue was not being able to use the 2nd joystick and button setup, this was resolved by modifying /boot/cmdline.txt by adding the following content after a space at the end of the first line “usbhid.quirks=0x16c0:0x05e1:0x040”

    I was then able to see two distinct controllers in jstest, configure 2 gamepads in emulationstation, and setup buttons for SFII in Mame.

    that is all my technical issues resolved, arcade cabinet is mostly assembled so I am doing some undercoating tomorrow.

    Again many thanks to the forum members and particularly contributors to this thread, without your efforts I would still be wondering why I couldn’t see my joystick.


    Post count: 32

    Ok, so it seems like this is a linux kernel error and maybe hard to fix. (Hoping I’m wrong) And I got no answers so lets move on! Do anybody know how well the Ipac is working with RetroPie? Or should I just get an old keyboard and solder the wires to it? Maybe some other alternatives as well?

    Or if someone is kindly enough to send me the RetroPie 3.2.1 image so I can try the patch from this reddit thread:

    Post count: 32

    So I solved the problem with the player one showed up as player two and vice versa.
    When I connected the cables I did it according to the PC-wiring picture, but you should look at the PS3-wiring picture. When I changed the cables the player one became player one, success!

    Post count: 32

    I’ve found a solution for my problems with the Xin-Mo and I wrote a guide if somebody is having the same problems. Here it is: Xin-Mo Guide

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.