Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • justplanechad
    Participant
    Post count: 2

    This is my first post here so I hope it’s in the right place. In the past I have been able to use xbox one controllers no problem, but recently I decided to reinstall retropie and set it up with xbox controllers, but when i plugged in both of my controllers it doesnt detect them as gamepads. they vibrate as if they are getting power, yet they dont get recognized. when I use lsusb it shows up, so the only thing i could think of is that it was software based since the xbox one controllers run off their own software. I used my roommates xbox controller that he hasn’t updated recently and it worked fine, but once i updated it i had the same problem as my controllers. i saw somebody else post about a similar issue and they thought it was the build model, but from my experience im thinking its the software version. does anyone have any idea on how to get it to work? or am i just going to have to wait for xboxdrv to be updated?

    herbfargus
    Member
    Post count: 1858

    I’ve heard of similar issues as well. It’s almost as if Microsoft doesn’t want people using their controllers for anything but the XBOX… actually very few controllers are ever designed for linux so we’ll always be running into these issues. so unless you find a way to downgrade the firmware on the controller (which I don’t know how that would be possible) you may just have to wait til xboxdrv is updated. I don’t have an xbox one controller so I could be totally wrong as well.

    justplanechad
    Participant
    Post count: 2

    Hmmm yeah that’s what I was thinking. Who knows maybe they don’t seeing as the wireless adapter has been marketed as “strictly windows”. I’ll post back any discoveries I make.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.