Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • hurders
    Participant
    Post count: 3

    Installed the xboxdrv and configured RetroArch settings to map all buttons including analog etc. but playing games the analog sticks don’t seem to work, although the buttons do e.g. clicking the sticks in. Can’t figure out quite why that would be, any ideas?

    Also how do you get vibration/rumble to work e.g. with PSX games?

    proxycell
    Participant
    Post count: 203

    ok, so you’re trying to get the analogue sticks to work with the ps1 games as well? could be the emulator itself.

    hurders
    Participant
    Post count: 3

    [quote=81895]ok, so you’re trying to get the analogue sticks to work with the ps1 games as well? could be the emulator itself.[/quote]

    That’s what I’m trying to achieve yes.

    I configure the xbox controller retroarch settings through the Retro-Pie setup where it recognises the analogue axis and registers them ok. But, it doesn’t seem to enable the analogue axis when running PSX games? Neither do I get any vibration feedback which I assumed would also work?

    Odd thing is that as I mentioned before, clicking the analogue sticks (L3 and R3) work ok in the psx emulator.

    What am I missing?

    I even pasted the controller config at the bottom of the main retroarch.cfg file as deatailed below but still not working:

    input_player1_joypad_index = “0”
    input_player1_b_btn = “1”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-5”
    input_player1_down_axis = “+5”
    input_player1_left_axis = “-4”
    input_player1_right_axis = “+4”
    input_player1_a_btn = “0”
    input_player1_x_btn = “2”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “11”
    input_player1_r3_btn = “12”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_enable_hotkey_btn = “8”
    input_save_state_btn = “5”
    input_enable_hotkey_btn = “8”
    input_load_state_btn = “4”
    input_enable_hotkey_btn = “8”
    input_state_slot_increase_btn = “7”
    input_enable_hotkey_btn = “8”
    input_state_slot_decrease_btn =”6″
    input_enable_hotkey_bn = “8”

    Any suggestions?

    imnew
    Participant
    Post count: 13

    I’ve not yet had one response on this retropie site – can someone please let me know if they can see this? I’m not sure if my accounts screwed or something weird (invisibility mode?!)

    thanks

    proxycell
    Participant
    Post count: 203

    hi imnew – yes we can see your post here, are you also having trouble with the ps1 emulator and controller?


    @hurders
    : ok, i really need to test out the ps1 emulator myself sometime… my advice to you for now is to basically start from 100% scratch with the retropie 2.3 image. do not touch any other emulators, add in a few ps1 games/bios and try from there.

    try not pasting in the config?

    i’ll learn as I go too

    imnew
    Participant
    Post count: 13

    @proxycell – no I’m not thanks, I was just really unsure whether I was actually visible or not. Apologies to OP for any confusion, thanks for clearing that up

    hurders
    Participant
    Post count: 3

    Ok, I’ve managed to sort out the analogue stick issue.

    I set a hotkey to let me go into the actual emulator menu when its running and then there are options to set the input as a joypad with analogue. Then you can write those settings out to a new config. I then opened that new config up and copied all the input settings into my main retroarch.cfg which then lets all retroarch emulators boot up with analogue enable by default. Still no vibration feedback but I’m thinking this isn’t a working option on PSX emulation via retroarch? Either way I’m not too fussed as PSX emulation ain’t something I’ll really bother with.

    If anyones interested, here is the input settings I use. Just copy and paste these to the end of your retroarch.cfg and providing you are using a wireless 360 controller it should enable analogue by default and it also lets you use the sticks to control d-pad which is useful for SNES etc:

    input_device_p1 = “0”
    input_player1_joypad_index = “0”
    input_libretro_device_p1 = “5”
    input_player1_analog_dpad_mode = “1”
    input_player1_b = “z”
    input_player1_b_btn = “1”
    input_player1_b_axis = “nul”
    input_player1_y = “a”
    input_player1_y_btn = “3”
    input_player1_y_axis = “nul”
    input_player1_select = “rshift”
    input_player1_select_btn = “8”
    input_player1_select_axis = “nul”
    input_player1_start = “enter”
    input_player1_start_btn = “9”
    input_player1_start_axis = “nul”
    input_player1_up = “up”
    input_player1_up_btn = “h0up”
    input_player1_up_axis = “nul”
    input_player1_down = “down”
    input_player1_down_btn = “h0down”
    input_player1_down_axis = “nul”
    input_player1_left = “left”
    input_player1_left_btn = “h0left”
    input_player1_left_axis = “nul”
    input_player1_right = “right”
    input_player1_right_btn = “h0right”
    input_player1_right_axis = “nul”
    input_player1_a = “x”
    input_player1_a_btn = “0”
    input_player1_a_axis = “nul”
    input_player1_x = “s”
    input_player1_x_btn = “2”
    input_player1_x_axis = “nul”
    input_player1_l = “q”
    input_player1_l_btn = “4”
    input_player1_l_axis = “nul”
    input_player1_r = “w”
    input_player1_r_btn = “5”
    input_player1_r_axis = “nul”
    input_player1_l2 = “nul”
    input_player1_l2_btn = “6”
    input_player1_l2_axis = “nul”
    input_player1_r2 = “nul”
    input_player1_r2_btn = “7”
    input_player1_r2_axis = “nul”
    input_player1_l3 = “nul”
    input_player1_l3_btn = “11”
    input_player1_l3_axis = “nul”
    input_player1_r3 = “nul”
    input_player1_r3_btn = “12”
    input_player1_r3_axis = “nul”
    input_player1_l_x_plus = “nul”
    input_player1_l_x_plus_btn = “nul”
    input_player1_l_x_plus_axis = “+0”

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.