Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • wazzul
    Post count: 1


    I’m pretty new to programming but I know the basics so any help on my problem in the simplest form would be greatly appreciated. So I recently purchased a Raspberry Pi 2 and installed Retropie. I have a simple logitech keyboard, Xbox 360 receiver (with controller), and a wifi dongle all connected to the pi. Everything seems to work correctly, I can use my controller in EmulationStation but when I go to load a ROM (The Legend Of Zelda on NES for example) none of the buttons work except for Select, which moves my selector down, and Start, which selects things. I’ve tried going into retroarch and configuring the controller but even after that it still continues to not work.

    Any help would be greatly appreciated,
    Thank you!

    Post count: 20

    Are you using 3.0 or 2.6?

    If 2.6, have you completed the retroarch joyconfig? No? Do this:

    Press F4 to exit ES

    sudo chown pi /opt/retropie/configs/all/retroarch.cfg (only once)
    cd /opt/retropie/emulators/retroarch/bin
    sudo ../retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    For the 2nd controller use -j 1 >> and so on…

    Post count: 3

    If you have installed V3 beta 4, i had problems too.
    Looked like the config would not be saved for the retroarch.
    I installed the Beta 3 and all worked.

    Post count: 51

    From retroarch, write the config to file. Retroarch create a .cfg file. Copy and Rename this file to retroarch.cfg inside the directory of emulator, eg: /opt/retropie/configs/psx/

    Now it should work!

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.