Homepage Forums RetroPie Project Everything else related to the RetroPie Project X-Arcade Tankstick – what am I doing wrong?

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #92970

    I understand from reading the blog entry from last year that my Tankstick OUGHT to work properly with the XArcade2joystick service enabled. After getting a clean 3.0 Beta SD image installed the other night, and copying my ROMS back to the proper directories, I rebooted my Pi 2, fired up Emulationstation and gave things a try.

    First off, after enabling the service I can no longer navigate in Emulationstation menus using the X-Arcade stick and buttons. Keyboard navigation works okay using arrow keys and CTRL and ALT to select and back out of menu items. While this is awkward, it does work.

    Second, while I can use the joystick itself in the emulators I’ve tried (MAME4ALL, Atari800, and ProSystem), the button assignments are not at all what I expect. Worse, I can’t use the Coin and Player 1/Player 2 buttons to start games, select options, etc.

    So my question is, where are the config files for the XArcade2joystick service, and are they configurable per emulator? For instance, I’d love to be able to set some of those “extra” buttons on the Tankstick for the Start, Select, Option and System Reset buttons on the Atari800 emulator. Similarly, I’d like to be set the player 1 and 2 difficulty settings in Stella and ProSystem, as well as the ProSystem pause button …

    Anyway, any pointers would be appreciated, thanks!


    Okay, I figured out how to get the joysticks and buttons registered for MAME4ALL. I guess I can figure out each of the rest of the emulators individually.

    So my question now boils down to this all-important one: how do I enable trackball support in MAME4ALL? Centipede and Missile Command just ain’t right with the joystick!


    I’m having the same issue. I’ve got everything else wit the tankstick working well, but the trackball doesn’t work with any MAME4ALL games. It does work in the ScummVM UI. If anyone can help out, it would be much appreciated. Thanks!


    As a follow-up to my own post, after googling, it appears as if there simply is no trackball/mouse support in MAME4ALL. The Tankstick works fine with AdvanacedMAME provided there is no other mouse plugged into the Pi. Since I have a Pi 2 and don’t play anything newer than about the mid-80’s, I’ve essentially just defaulted to using AdvancedMAME with my .106 roms for my favorite games. Shame, really, but I just don’t know if there’s a solution. I was hoping one of the RetroPie experts would be able to chime in definitively. It’s not like the trackball or a mouse is such a unique accessory for MAME.


    Thanks for the info drvenkman. I was coming to the same conclusion as well, but it would be nice to hear a clearer answer from someone in the know.

    From what I gathered, the main reason to use MAME4ALL is performance, but since the Pi 2 is faster, maybe that isn’t as much of an issue? Mabye I’ll switch to AdvancedMAME and see how it goes.


    Anyone have anything else to add to this? Are we out of luck? Sure would love to play some Marble Madness. :)


    I have the tankstick working with 2.6 with the trackball.
    After following the steps below, you will need to remap your keys in MAME with the MAME TAB menu.

    1. Do not use the Xarcade2Jstick – it disables the trackball
    2. Edit /opt/retropie/configs/all/retroarch.cfg
    I am not sure if this is in the same place with 3.0.
    3. Modify the following lines;
    input_player1_a = z
    input_player1_b = shift
    input_player1_y = ctrl
    input_player1_x = alt
    input_player1_start = num5
    input_player1_select = c
    input_player1_l = space
    input_player1_r = x
    input_player1_left = keypad4
    input_player1_right = keypad6
    input_player1_up = keypad8
    input_player1_down = keypad2

    4. Add the following lines;
    input_player2_a = e
    input_player2_b = w
    input_player2_y = a
    input_player2_x = s
    input_player2_start = num6
    input_player2_select = rightbracket
    input_player2_l = q
    input_player2_r = leftbracket
    input_player2_left = d
    input_player2_right = g
    input_player2_up = r
    input_player2_down = f


    [quote=94162]I have the tankstick working with 2.6 with the trackball.
    After following the steps below, you will need to remap your keys in MAME with the MAME TAB menu.


    To be clear, is this in MAME4ALL? Because the trackball is already working in AdvMAME and the Xarcade2jstick service has things working very well in the rest of my usual emulators (Stella, ProSystem, Hatari, VICE …)


    Same here, trackball is working fine with Xarcade2jstick in other emulators and I’m using MAME4ALL too.


    [quote=94246]Same here, trackball is working fine with Xarcade2jstick in other emulators and I’m using MAME4ALL too.[/quote]

    Alright then – this is good info. I’ll dig into the config files over the weekend when I have a little time and give it a try. Thanks!


    The tankstick works like a keyboard and mouse when not using the driver.
    I wanted the trackball in mame4all because ADVMame does not work for the Pi B+.


    Well I tried disabling the Xarcade2jstick service then making all the suggested changes – ugh. I could no longer navigate the EmulationStation UI without determining which random buttons or joystick movement did what … despite double-checking the .cfg file twice and rebooting twice, it just didn’t work. The hell of it was I couldn’t even get further than the Centipede attract screen – nothing I was trying, on either the Tankstick or the keyboard, would start the game.

    I finally had to give up and reinstalled the Xarcade2jtick service – I’ll just stick to AdvMAME for my trackball games.

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.