Homepage Forums RetroPie Project New to RetroPie? Start Here! Web browser on retropi/raspbian?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #102645


    I´m running retropie och my Pi, and everything seems to be working great, except the fact that I´m missing a web browser. I don’t know if there is one included in the pre-compiled image (2.6). I tried to download midori but it wouldnt run (“cannot open display”)

    I would be greatful if someone could point me in a direction to a lightweigh browser that works on raspbian/retropie =)


    Ok, I got some more information for you guys. Seems like all these browseras are dependent of X. But when I try to sudo startx, the screen goes black with a tiny white bash square, showing the user root. No input is possible, and I tried waiting a long time but nothing happens.


    startx will just start the X server / environment and by default just start xterm, not the browser (You also shouldn’t be running it as root). RetroPie doesn’t come with a full X desktop environment to keep the size down.

    if you have installed midori, you can start it by installing a window manager and making a small script

    sudo apt-get install matchbox-window-manager

    then create a script in your homedir called browser.sh containing

    matchbox-window-manager &

    make sure it has executable permissions (chmod u+x browser.sh)

    then you can do

    xinit ~/browser.sh

    to launch X and run the script which loads the window manager and browser.


    Alternatively if you want the whole desktop thing back you can do sudo apt-get install lxde


    Work wonders! Thanx for the advice guys!


    I am having trouble with startx. I am running retropie v3.1 on berryboot on my rpi2. I tried installing lxde with sudo apt-get install lxde, and immediately following installation I ran sudo raspi-configuration so that emulationstation would load on startup. When I exit out to terminal after emulation station loads up and try startx the screen goes black and nothing happens and I have to restart my pi. I tried apt-get update then upgrade then reinstalling lxde but still having the same problem. Never had this issue with 3.0

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.