Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • disrespect
    Participant
    Post count: 16

    Pi Model: B+
    RetroPie Version Used: 3.3
    Built From: SD Image
    USB Devices connected: mini USB wifi dongle /WD 500gb passport mini HD/ 2x controller (give or take)
    Controller used: SNES Usb, or Sixaxis
    Error messages received: NA
    Guide used: NA

    Issue: PI2 works great, emus are up just fine. I’m trying to get my PSX isos on the passport external HDD to pick up. Here’s what I’ve done so far:

    *sudo apt for NTFS-3g package on the pi
    *sudo blkid shows drive is connected at dev/sda1
    *Voltage to ports increased, I confirm drive is powered well enough. I have a backup usb hub I have tried, voltage is not the issue. Drive+PI are on enough juice.

    *edited etc/fstab with the following:
    UUID=3C180DE0180D99D2 ntfs-3g defaults,permissions,locale-en_US.utf8 0 0

    (I was suggested to mount by UUID instead of relying on the port)

    sudo blkid output: (I’m not sure why I see this drive labeled twice at different locations)

    /dev/sda1: LABEL=”external” UUID=”3C180DE0180D99D2″ TYPE=”ntfs”
    /dev/sr0: LABEL=”WD SmartWare” TYPE=”ntfs”

    I edited es_systems.cfg to point to what I thought was the correct directory, I have tried:

    /dev/sda1/PSX
    /media/external/PSX

    any thoughts?

    InsecureSpike
    Participant
    Post count: 571

    well I used to run my system from my USB, but now I’ve changed my setup to using USB only for roms and sd for system files,

    ok here’s what I did and all works perfect,

    since you’ve done a lot of work already I’d suggest trying this as your addressing your es_systems.cfg

    /media/usb0/PSX

    if no good I’ll go through my step by step set up

    disrespect
    Participant
    Post count: 16

    if no good I’ll go through my step by step set up

    Let me see what you did, maybe it will show where I went wrong. For what it’s worth, I see my drive on sudo blkid but not ls /media/usb* (which SHOULD show a drive, right?)

    InsecureSpike
    Participant
    Post count: 571

    I’d like just to point out, I’m not saying this is the way this should be done, this is the way I have done it & it works well for me

    ok, here goes,

    firstly I edited /boot/config.txt on a fresh RetroPie image.

    sudo nano /boot/config.txt

    adding right at the bottom

    max_usb_current=1

    next I format the drive to ext4 via a spare rPi running Raspbian, using gparted

    sudo apt-get install gparted

    next boot the RetroPie image I prepared earlier, with the drive in.
    once set up RetroPie, I set permissions on the drive with, this will allow to add files as & when needed via ftp

    sudo chown -R pi:pi /media/usb0

    now I don’t use any uuid’s as I don’t plan on using any other drives, (I use a 128gb USB drive)

    then i can create folders & add roms…

    then edit the es_systems.cfg

    pointing directories to

    /media/usb0/

    InsecureSpike
    Participant
    Post count: 571

    but, if your other roms are showing up fine then there may be another reason, maybe something simple, maybe….

    uppercase or lowercase text?

    rdhanded2
    Participant
    Post count: 132

    Format the drive fat32

    disrespect
    Participant
    Post count: 16

    Insecure spike did you have to edit fstab to make the drive mount automatically at every boot? I don’t see anything about it there.

    InsecureSpike
    Participant
    Post count: 571

    no mate usb’s auto mount, in RetroPie

    disrespect
    Participant
    Post count: 16

    [quote=112949]no mate usb’s auto mount, in RetroPie

    [/quote]

    I bet that’s what my problem is, I’ve been tweaking with fstab file thinking it matters here

    InsecureSpike
    Participant
    Post count: 571

    quite possible, mate

    disrespect
    Participant
    Post count: 16

    I think it may be working now:
    *deleted altered entries in /etc/fstab
    *formatted 500gb drive to ext4
    *ftp’d an iso over to it as a test (took a horrible long time at around 250k/s)
    *altered path for PSX to /media/usb0/psx , ISO is found and working

    Is there a way to tell by command what capacity there is available on the drive? or through emulationstation? I can see the SD card capacity through ‘sudo blkid’ but that doesn’t list the external drive space.

    InsecureSpike
    Participant
    Post count: 571

    df -h

    disrespect
    Participant
    Post count: 16

    [quote=112993]df -h

    [/quote]

    You’re awesome, thanks. That confirms it’s connected and at the right size ;)

    InsecureSpike
    Participant
    Post count: 571

    your welcome fella, glad ya got it all sorted!

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.