Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • photon
    Participant
    Post count: 3

    I’m setting up retropie 3.3 on a pi2. I’m using a vga monitor with a HD to vga converter (startech HD2VGAE2). It was working fine and everything was going smoothly. I was able to configure my controller and load roms. The next time I booted up the pi, the monitor now displays the message ” cannot display this video mode”. I have no idea what changed. Any suggestions appreciated.

    Thanks
    Peter

    photon
    Participant
    Post count: 3

    It turns out I can get the monitor to display if I turn it on before booting the pi. I was starting them “at the same time” using the switch on the power strip they are both plugged into.
    Unfortunately, this is the arrangement I’ll need to use as everything will be integrated into a cabinet? Does anyone know a work around?

    davej
    Participant
    Post count: 21

    You can configure the mode to use by setting the hdmi_group and hdmi_mode values in /boot/config.txt – see config.txt documentation on raspberrypi.org.

    You can find out which values to set as follows:

    [ul]

  • Boot your Pi having switched the monitor on first so you get a picture.

    Run [b]tvservice -s[/b]

    This will display something like:[code]state 0x120016 [DVI DMT (58) RGB full 16:10], 1680×1050 @ 60.00Hz, progressive[/code]The important bit is the DMT (58). You might have CEA instead of DMT – whichever it is defines the value to use for hdmi_group (1 for CEA, 2 for DMT). The value in brackets is the one to use for hdmi_mode.

  • You can find out which modes your screen supports by running [b]tvservice -m DMT[/b] (or CEA if tvservice -s returned that) and pick another one if you like. It’s a good idea to use one that is 60Hz as that matches the vsync rate games are written to work at.
  • Edit /boot/config.txt and add hdmi_group and hdmi_mode lines with values found above.
  • [/ul]