Homepage Forums RetroPie Project Controller Configuration in RetroPie USB HID PlayStation 4-port adapter

Viewing 1 post (of 1 total)
  • Author
  • #121173

    I’m trying to get a USB HID PlayStation 4-port adapter working with RetroPie 3.6 on a 512MB Raspberry Pi B.

    The device is picked up by the kernel just fine: I can see from dmesg that it’s recognized.

    [ 2.025324] hid-generic 0003:0925:8884.0001: input,hidraw0: USB HID v1.00 Joystick [HID 0925:8884] on usb-20980000.usb-1.2/input0

    Emulation Station sees this device as a single gamepad even if two devices are connected, but that’s OK for the time being. I can configure the device easily and navigate EmulationStation just fine with it.

    Here is the relevant section of es_input.cfg:

    <inputConfig type=”joystick” deviceName=”HID 0925:8884″ deviceGUID=”03000000250900008488000000010000″>
    <input name=”a” type=”button” id=”1″ value=”1″ />
    <input name=”b” type=”button” id=”2″ value=”1″ />
    <input name=”down” type=”hat” id=”0″ value=”4″ />
    <input name=”left” type=”hat” id=”0″ value=”8″ />
    <input name=”leftanalogdown” type=”axis” id=”1″ value=”1″ />
    <input name=”leftanalogleft” type=”axis” id=”0″ value=”-1″ />
    <input name=”leftanalogright” type=”axis” id=”0″ value=”1″ />
    <input name=”leftanalogup” type=”axis” id=”1″ value=”-1″ />
    <input name=”leftbottom” type=”button” id=”4″ value=”1″ />
    <input name=”leftthumb” type=”button” id=”10″ value=”1″ />
    <input name=”lefttop” type=”button” id=”6″ value=”1″ />
    <input name=”right” type=”hat” id=”0″ value=”2″ />
    <input name=”rightanalogdown” type=”axis” id=”3″ value=”1″ />
    <input name=”rightanalogleft” type=”axis” id=”2″ value=”-1″ />
    <input name=”rightanalogright” type=”axis” id=”2″ value=”1″ />
    <input name=”rightanalogup” type=”axis” id=”3″ value=”-1″ />
    <input name=”rightbottom” type=”button” id=”5″ value=”1″ />
    <input name=”rightthumb” type=”button” id=”11″ value=”1″ />
    <input name=”righttop” type=”button” id=”7″ value=”1″ />
    <input name=”select” type=”button” id=”9″ value=”1″ />
    <input name=”start” type=”button” id=”8″ value=”1″ />
    <input name=”up” type=”hat” id=”0″ value=”1″ />
    <input name=”x” type=”button” id=”0″ value=”1″ />
    <input name=”y” type=”button” id=”3″ value=”1″ />

    I cannot get this controller recongized anywhere within RetroArch, however. I don’t get any yellow message on the screen when any emulator starts – the only input source RetroArch seems to be aware of is the keyboard.

    My retroarch.cfg: http://pastebin.com/hkDMqDPF

    I have tried both udev and hid for input drivers – no luck.

    I have tried to manually config the controllers from within RetroArch but the ports always show up as “N/A”.

    Any advice/suggestions?

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.