Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • JesseAcosta
    Post count: 3

    Hello all. I’m obviously fairly new to RetroPie and Raspberry Pi. I’m having issues setting up my gamepad to work with my setup. It works fine within the Emulation Station, but when I’m in a game(trying out Super Mario Bros), the button configuration is all wrong. The only thing right are my start and select, and if I press both I can get back out of the game. One other button will make my character jump and run right at the same time, that’s about it.

    I used this tutorial to setup my Raspberry Pi with RetroPie:
    Everything seems to work fine in the tutorial except for the controller setup. They wanted me to type 322 in the setup menu, which wasn’t for gamepad configuration. I’m assuming something had changed in an update. I found it under 320, and then I pressed 1 to configure the controller for RetroArch. The file it saved my controller configuration under was USBWheel.cfg. I’m using a Hyperkin SNES style USB controller. I have a few USB Playstation style controllers coming in the mail that I’ll be using in the future. More button options for gaming.

    Any suggestions to get me going? Maybe it’s my gamepad? Though I’ve never had trouble with it before.


    Post count: 1858

    What version of retropie are you using? I’d suggest using retropie 3 beta 4 as it has a lot of fixes regarding controller configurations. (The emulation station configuration will also configure retroarch for you)

    Post count: 3

    i have the same problem here, with version 3 beta 4.
    Ok, i have this Pad
    I can make the configuration in retropi and also use it in emulationstation.
    But if i start nes oder snes (didn’t tried any thing else yet) it only works a button like shooting ore jumping.
    I can still use the keyboard config.


    Post count: 3


    I used retropie-v3.0beta3-rpi2.img to make my RetroPie image.

    Post count: 3

    There is only the beta 4 now for download.

    For mit look like, that it is not saving the config.
    If i reboot the pi, than the config is lost.
    Only the A button is still there.

    Post count: 3

    I solved my issue. I did a search for USBWheel and Retropie and found this article:

    It appears that the CFG USBWheel___.cfg is being written wrong for the d pad.

    I had to change these lines:
    input_up_btn = “-1”
    input_right_btn = “+0”
    input_down_btn = “+1”
    input_left_btn = “-0”

    into these lines:
    input_up_axis = “-1”
    input_right_axis = “+0”
    input_down_axis = “+1”
    input_left_axis = “-0”

    Very bizarre, but now it’s working for me.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.