Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • animator84
    Participant
    Post count: 3

    I’m on Retropie 2.6, have been trying to update the RetroPie setup script with no avail. Apt-get and selelecting the “Binaries-based installation” are all fine, but when I select “UPDATE RetroPie Setup script”,

    it prints :

    ======================================
    Fetching latest version of the setup script
    =======================================
    /home/pi/RetroPie-Setup /home/pi/RetroPie-Setup

    then a dialogue box pops up :

    Update failed:
    fatal: unable to connect to github.com: github.com: no address associated with hostname

    I have no idea what is happening, can someone help me. I’ve Ping github.com successfully.

    petrockblog
    Keymaster
    Post count: 1827

    You have a networking issue – possibly dns – Make sure the pi has full internet access and try again perhaps. How is your pi connected ?

    animator84
    Participant
    Post count: 3

    Hey I solved it, some googling pointed me to this command

    sudo sh -c ‘echo “nameserver 8.8.8.8” > /etc/resolv.conf’

    and after running this command, it worked. Can someone tell me why my pi has this issue and what this command is doing? my pi is connected via ethernet

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.