Homepage Forums RetroPie Project Everything else related to the RetroPie Project Uninstall Retropie + fresh install

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #118047

    As I have the feeling that my last installs broke something, I want to uninstall Retropie completely and do a fresh install – so how can I uninstall Retropie completely?

    Regarding the fresh-install-process, is it actually possible to install only some emus one by one from source manually, does it work fine or are there any problems? Is it better to do it from source or use the binaries?


    Update your setup script

    And your uninstall option will be there.


    Make a backup first as you may have problems as the uninstall feature is still a bit Experimental.

    You can manually install things but you have to know what you’re doing. Dont install from sourcw, use binaries. It’s easiest to do a full binary install and then remove the things you dont want manually. We’ll eventually integrate uninstalling pieces from the setup script but for now you just have to use the terminal or winscp as root.


    Here’s a page on manually installing parts of retropie:



    Thanks, uninstall+reinstall were fine –
    but I still get an errormessage when leaving ES, saying something like

    “lvl0: …init: failed to load Mixer-elements”…is that normal?

    [quote=118049]You can manually install things but you have to know what you’re doing. [/quote]
    My idea of sorting the install-menu in a way like this

    [*] Emulationstation (neccessary GUI)
    [ ] RetroArch addon (Libretro-core)

    Emulators for RetroArch (Libretro):
    [ ] (Libretro) Atari
    [ ] (Libretro) …
    [ ] (Libretro) …

    Emulators standalone:
    [ ] …
    [ ] …
    [ ] …

    would make this step easier in my opinion, doesn’t it?

    However, is the still shown audio-errormessage normal actually?


    [quote=118075]but I still get an errormessage when leaving ES, saying something like

    “lvl0: …init: failed to load Mixer-elements”…is that normal?[/quote]

    Are you using a USB sound card? I am, and I get this error. It works in some situations, but scripts that try to use simple channel named “PCM” for example will fail. That usually means any “Save state” scripts probably designed to save volume settings fail, even though an emulator might work fine using default audio. I have search high and low for a COMPLETE solution for USB audio. I am still looking.


    No, I use standard audio through hdmi, without a soundcard.


    And I found out that it makes no difference if set set audio output correct to hdmi in the post-install-Retropie-Setup-Script menupoint – I still get this message.

    Furthermore I found out, that in around 1 of 3 exits to the commandline of my latest EmulationStation-install the system crashes/ hang up completely (what is very “funny” if you entered the third time (until now without success – don’t know how I should get it to save that) the correct names of over 20 ScummVM-games through select and editing their metadata within ES….)…but thats another topic.

    Edit: 4 times^^…(but this time I only renamed a few ones)
    Retropie also crashes here/ hang with a blinking cursor if I try to restart the system instead of exiting ES to the commandline.

    Don’t know whats wrong – but I did a fresh install yesterday.


    In the meanwhile I installed ES and Scumm from source,
    but no chance – if I change metadata from Scumm-games and try to exit ES – whichever exitoption I take – the system crashes/hangs…

    I’ll try RetroPie again when the next release is coming out.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.