Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • link2803
    Participant
    Post count: 4

    Hi all,

    I’m hoping someone can help me here before I start tearing my hair out! I love RetroPie and have everything set up exactly how I want except one specific issue which is bugging me.

    I’m using a wireless 360 controller with no problems at all over a majority of systems but I’m wanting to remap a few buttons, specifically the A and B buttons for NES and Gameboy.

    No matter what I do, I can’t seem to override the “input_player_*_btn” values in the “configs/all/retroarch.cfg” file. When I edit the system-specific file (“configs/<system>/retroarch.cfg”), RetroArch reads all other override values – I’ve tested this with the “video_shader_enable” value which reads correctly – but not remapping commands.

    I’ve enabled / disabled “input_remap_binds_enable”, “input_autodetect_enable” and “core_specific_config” but to no effect. I can remap within RetroArch’s GUI and this works fine until I exit and re-load whereby the default controls are reset.

    For clarity, here is my nes/retroarch.cfg file:

    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    # All settings made here will override the global settings for the current emulator core
    input_remapping_directory = /opt/retropie/configs/nes/
    video_shader = /opt/retropie/emulators/retroarch/shader/phosphor.glslp
    video_shader_enable = true
    video_smooth = false
    input_remap_binds_enable = true
    input_player1_b = "2"
    input_player1_a = "0"
    input_player2_b = "2"
    input_player2_a = "0"
    

    I’m using RetroPie v3 on an RPi1 B+, standard configuration for RetroArch and ES (experimental Kodi installation in case that makes any difference at all). I’ve trawled every resource I can get hold of and just cannot get this one small issue fixed.

    Is something telling RetroArch to reset the remap commands? Am I passing commands through in the wrong format? Any advice would be greatly appreciated.

    Floob
    Member
    Post count: 1629

    In short, try putting your overrides at the very top of the file at
    /opt/retropie/configs/{systemname}/retroarch.cfg
    (Dont edit the one in /all/)

    In long, watch this video:

    link2803
    Participant
    Post count: 4

    Thanks, that seems to do the trick. It’s not the most elegant way of remapping but I’ll only have to do it once for each system I use.

    Floob
    Member
    Post count: 1629

    If you want the remapping to be the same for all systems, you could just edit the controller file in
    /opt/retropie/emulators/retroarch/configs/

    The one you use is shown when you start a game – the name will appear in yellow text at the bottom of the screen.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.