Tagged: ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • peer1979
    Post count: 4

    I need some help to connect my alternative PS3 controller to retropie. It will not pair and i’m wondering what i can do to fix it.
    It is not detected by the emulation station setup, retropie_setup or sixad.

    Pi Model: B
    RetroPie Version Used: SD-card image Version 3.5 for Raspberry Pi 1 and Pi Zero
    Built From: SD Image
    USB Devices connected: Bluetooth dongle, alternative ps3 controller
    Controller used: Envivo PS3 Controller (alternative controller)
    Error messages received: none
    Guide used: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-a-PS3-controller
    How to replicate the problem: ogin with ssh > retropie_setup.sh > update setup script > install ps3 controller > no pairing


    I’ve followed the guide several times, but pairing will not happen. I’ve tried all profiles, but no effect. Then i’ve tried to check everything,
    with my limited Linux knowledge and the second part of the guide for older versions. Here are some screenshots from lsusb, hciconfig, sixpair:

    Then i perform:

    sixad –stop
    sixad –start

    Sixad says i have to press the PS button, but nothing happens, no matter how long i press it. I’ve also noticed that dev/input/js0 does not exist.

    The controller works on a windows machine.


    What do i need to do to fix this?
    Is a powered usb hub required?
    Can the ps3 controller work when it’s connected with usb instead of the bluetooth dongle?
    Could i perhaps create a custom profile somewhere?

    Post count: 4

    Sorry, wrong category. Could a forum admin put it in the right category? Thanks :)

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.