Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • bobdor
    Post count: 2


    I am attempting to set up my first RetroPie project and I ran into a snag. I am trying to use a wired 360 controller with my setup. I followed the tutorial here: and from what I have read around the internet, “Method 3” appears to be widely accepted as the best way to go about this. It is however, not working for me. on boot up, towards the end of the sequence I get a message along the lines of:

    [FAIL] Startpar: Service(s) returned failure: xboxdrv [Failed!]

    That may not be the exact message I am typing it from memory, but it is close.

    Here is what I did:

    I first typed
    sudo apt-get install xboxdrv

    It took about a minute to install. Next I typed
    sudo nano /etc/init.d/xboxdrv

    This opened a blank document. I pressed [Ins] on the keyboard and inserted text from document I uploaded using WinSCP earlier. Then I ^w ^x out of the text editor.

    I then typed
    sudo chmod +x /etc/init.d/xboxdrv

    I double checked in WinSCP and saw the file go from -rwxr—– to -rwxr-x–x so that should be good.

    I then typed
    sudo update-rc.d xboxdrv start

    I checked WinSCP and I believe there was a shortcut in either rc5.d or rc4.d (I don’t remember which).

    I then followed the same procedure as earlier and typed
    sudo nano /etc/default/xboxdrv

    This opened a blank document. I pressed [Ins] on the keyboard and inserted text from document I uploaded using WinSCP earlier. I changed CONTROLLER_NUM=2 to 1 Then I ^w ^x out of the text editor.

    I figured that was the hard part. The next step in the tutorial is to Jstest the controller, but that doesn’t seem to work… I figured I would reboot the system. I did a:
    sudo shutdown -r now
    and when the system boots up I get the error message I mentioned earlier with a red FAIL. RetroPie is unable to see the controller connected.

    if I F4 out I can just
    sudo xboxdrv
    and it will assign the controller to js1, but never js0…

    I also tried editing the /etc/default/xboxdrv file by changing all the -w to -i. I also tried –id. same results.

    The only way I have been able to get the controller to work right is use “Method 1” on the tutorial. This will always make the controller js0, and I can setup everything with retroarch-joyconfig. I am at a loss on what I can be doing wrong with the daemon -D Option. It is literally copy pasted from the tutorial.

    Any help would be greatly appreciated.

    On a side note, in /dev/input/ I have 2 files, one called js0, the other js1. They are un-deletable. They were generated when I did the
    sudo xboxdrv
    command. Their chmod is sticky bit so it has rwxrwxrwxT. I don’t know if it is OK to leave them, if there is something wrong with them being, if that is normal and I am just lost.

    Thanks in advance.

    Post count: 2


    Post count: 2

    Just wondering if you found a solution to it ’cause I’m experiencing the exact same Problems with my wireless controlers…

    Post count: 2

    Nothing? Seems like an odd problem… can’t really find much about it…
    Or is it something you can safely ignore?

    Post count: 4

    ok, I am a major noob so this may or may not help. however I have been trying to set up multiplayer gaming using 2 xbox 360 wireless adaptors through trial and error (a hell of alot more error), I ended up half following the git hub site that you posted but the buttons were all wrong for me, so I edited the config file, at the very bottom where it says #player 1 down is what I use. it works for the dpad but i cannot get the analogue sticks working as yet. You may be able to copy and paste it into your config file.


    #Player 1
    input_player1_joypad_index = 0
    input_player1_b_btn = “0”
    input_player1_a_btn = “1”
    input_player1_y_btn = “2”
    input_player1_x_btn = “3”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_start_btn = “7”
    input_player1_select_btn = “6”
    input_player1_up_btn = “13”
    input_player1_down_btn = “14”
    input_player1_left_btn = “11”
    input_player1_right_btn = “12”Input_player2_l2_axis = “-2”
    Input_player1_r2_btn = “10”
    Input_player1_l3_btn = “9”
    Input_player1_r3_btn = “10”
    Input_player1_l_x_plus_btn = “+0”
    Input_player1_l_x_minus_btn = “-0”
    Input_player1_l_y_plus_btn = “+1”
    Input_player1_l_y_minus_btn = “-1”
    Input_player1_r_x_plus_btn = “+3”
    Input_player1_r_x_minus_btn = “-3”
    Input_player1_r_y_plus_btn = “+4”
    Input_player1_r_y_minus_axis = “-4”

    #Player 2
    input_player2_joypad_index = 1
    input_player2_b_btn = 0
    input_player2_a_btn = 1
    input_player2_y_btn = 2
    input_player2_x_btn = 3
    input_player2_l_btn = 4
    input_player2_r_btn = 5
    input_player2_start_btn = 7
    input_player2_select_btn = 6
    input_player2_up_btn = 13
    input_player2_down_btn = 14
    input_player2_left_btn = 11
    input_player2_right_btn = 12
    Input_player2_joypad_index = “1”
    Input_player2_b_axis = “-2”
    Input_player2_y_btn = “2”
    Input_player2_select_btn = “6”
    Input_player2_start_btn = “7”
    Input_player2_up_btn = “13”
    Input_player2_down_btn = “14”
    Input_player2_left_btn = “11”
    Input_player2_right_btn = “12”
    Input_player2_a_btn = “1”
    Input_player2_x_btn = “3”
    Input_player2_l_btn = “4”
    Input_player2_r_btn = “5”
    Input_player2_l2_axis = “-2”
    Input_player2_r2_btn = “10”
    Input_player2_l3_btn = “9”
    Input_player2_r3_btn = “10”
    Input_player2_l_x_plus_btn = “+0”
    Input_player2_l_x_minus_btn = “-0”
    Input_player2_l_y_plus_btn = “+1”
    Input_player2_l_y_minus_btn = “-1”
    Input_player2_r_x_plus_btn = “+3”
    Input_player2_r_x_minus_btn = “-3”
    Input_player2_r_y_plus_btn = “+4”
    Input_player2_r_y_minus_axis = “-4”

    someone with more experience may be able to help more/get the joysticks working, there is a stickied post at the top with what controllers people are using and has some config files data that may help.


Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.