Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • darktrooper
    Post count: 12

    I’ve had RetroPie working virtually flawlessly for the few weeks that I’ve been a Raspberry Pie2 owner.

    My ultimate aim was to have OpenELEC ( and RetroPie (2.6) both working from the same memory card as opposed to the 2 separate cards I was previously using.

    During the last few days and through a fair bit of help from here, online searching, guess work, head scratching and perseverance I’ve finally got things working as desired through BerryBoot.

    Unfortunately, I’ve now become stumped as to why RetroPie now totally refuses to play any sound through my TV (via HDMI). My previous builds never gave any problems but for reasons unknown with this newer version things aren’t going to plan.

    Booting into OpenELEC offers no problems with the sound working fine. Rebooting and going into RetroPie and things go silent again. I’ve tried plugging my earphones into the Pi and switching the audio to the 3.5mm jack and the sound is there (although a little hissy). Both Auto and HDMI settings (in the EmulationStation Setup menu) still seem to have no effect on getting my sound back through the TV.

    Strangely, I’ve plugged the Pi into my PC monitor (using the exact same HDMI cable) and fired up RertoPie and the sound works normally. I tried switching HDMI cables and sockets and trying again on my TV but again, no sound.

    Searching online doesn’t seem to bring up too much information apart from adding the ” hdmi_drive=2″ line to the Boot/configs.txt file which didn’t fix anything.

    If anyone has had similar issues and managed to find a fix, I’d love to hear about it.

    Post count: 12

    I have just noticed that when entering the RetroPie main menu and going to the Sound Settings, the volume is by default set to zero. I can use the slider to increase the volume but somehow it doesn’t save. I know this because if I quit back out of the menu and re-enter, the volume slider is back to zero again.

    Could this be my problem and is there a fix?

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.