Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • jamesq
    Post count: 5

    Hi guys, so I’ve been playing with retropie for some time now after researching a lot here and watching floob’s videos I set up my pi this way. I’d like some input about this so I can refine my installation and also share with other beginners my findings, so it makes it easy for them too. So, using ssh cyberduck’s software, enter server 192.168.1.xx (pi address), username p and pass raspberry I worked my way in easily to modifi rp’s contents.

    What I wanted was to put permanent shaders for hdmi tvs. Any input to improve this setup would be greatly appreciated. Thank you all :)

    Post count: 432

    progear works fine in lr-fba-next, FYI!

    Curiously, the mame emus are very picky with rom contents. Xor tables for finalburn games had to be found in order for them to work. It’s a nightmare to find every each little file that lacks in many roms.

    you shouldn’t have to do any of this :) if you use the correct rom set for the emulator, you shouldn’t need to manually locate any files. I’m not even sure what an XOR table is in this context!

    Post count: 5

    The romset for these old mame versions I don’t even know where to find and what version to look for. Also, it was sometimes written around here that not all roms work, even though they’re reported to work.

    xor tables are some missing files roms need.

    For example, D&D: Shadow over Mystara (Euro 960619) doesn’t work on mameadv if you don’t have dd2ex.04e and dd2ex.03e inside its zip. In fba, yes, perhaps (haven’t tried it). These can be found in a dedicated site, cps-2 shock.

    For fba, I even found a complete rom set from some guy over the internet that even though they supposedly work, in practice, some of its roms don’t. Pm me if you know more about this subject (roms, sets, etc).

    And it’s Good to know that progear works on fba! Thanks for that.

    Post count: 432

    it is definitely confusing but the information is out there:

    assuming you’re using advmame 1.2, the correct dat file references these files:

    <game name="ddsom" sourcefile="cps2.c">
    		<description>Dungeons & Dragons: Shadow over Mystara (Euro 960619)</description>
    		<rom name="dd2e.03e" size="524288" crc="449361af" sha1="14af2b35e6f43f92c9e071f1dc85b18cf73ecb35" region="cpu1" offset="0"/>
    		<rom name="dd2e.04e" size="524288" crc="5b7052b6" sha1="8a5f069f450da939d0f02518751cd9815d621d81" region="cpu1" offset="80000"/>
    		<rom name="dd2e.05e" size="524288" crc="788d5f60" sha1="b8b42c11530a34c2878fb119c0a388e33067b66d" region="cpu1" offset="100000"/>
    		<rom name="dd2e.06e" size="524288" crc="e0807e1e" sha1="4b978f5f647fff84d456eb14c9fd202d9a276997" region="cpu1" offset="180000"/>
    		<rom name="dd2e.07" size="524288" crc="bb777a02" sha1="4b2c65a9129fc2262b35be1c10d06f60f5108981" region="cpu1" offset="200000"/>
    		<rom name="dd2e.08" size="524288" crc="30970890" sha1="fd366a9323230f6997006ab4cc216f9a97865ebe" region="cpu1" offset="280000"/>
    		<rom name="dd2e.09" size="524288" crc="99e2194d" sha1="cbcecdf5beeac3eac6c2c3fa395710e1b8347531" region="cpu1" offset="300000"/>
    		<rom name="dd2e.10" size="524288" crc="e198805e" sha1="37ae9d88d98c59337b657cfa6feb56e4f9cae95f" region="cpu1" offset="380000"/>
    		<rom name="dd2ex.03e" size="524288" crc="bdbc9b38" sha1="4ccd94a588e6b24cb0e5ae91bcb6965d2de63380" region="user1" offset="0"/>
    		<rom name="dd2ex.04e" size="524288" crc="24d1be86" sha1="154c697b3a92eaf5a7c1c8dc083a78edb7def180" region="user1" offset="80000"/>
    		<rom name="dd2.13m" size="4194304" crc="a46b4e6e" sha1="fb90f42868c581c481b4ceff9f692753fb186b30" region="gfx1" offset="0"/>
    		<rom name="dd2.15m" size="4194304" crc="d5fc50fc" sha1="bc692f17b18bb47a724cd5152377cd5ccd6e184a" region="gfx1" offset="2"/>
    		<rom name="dd2.17m" size="4194304" crc="837c0867" sha1="3d6db290a8f76299a23543f0ccf6a7905e1088ac" region="gfx1" offset="4"/>
    		<rom name="dd2.19m" size="4194304" crc="bb0ec21c" sha1="e43ccc1cf63ccd2b504cc9fd701af849a7321914" region="gfx1" offset="6"/>
    		<rom name="dd2.14m" size="2097152" crc="6d824ce2" sha1="0ccfe6c8a944937718e28a1a373b5822c7b7001b" region="gfx1" offset="1000000"/>
    		<rom name="dd2.16m" size="2097152" crc="79682ae5" sha1="ee84f4791c29ce9e2bae06ba3ec47ff4d2cd7054" region="gfx1" offset="1000002"/>
    		<rom name="dd2.18m" size="2097152" crc="acddd149" sha1="7f50de9b2d1cc733594c642be1804190519caffa" region="gfx1" offset="1000004"/>
    		<rom name="dd2.20m" size="2097152" crc="117fb0c0" sha1="15c01fa1a71b6469b0e1bde0ce5835c5ff9d938c" region="gfx1" offset="1000006"/>
    		<rom name="dd2.01" size="131072" crc="99d657e5" sha1="1528dd6b07a0e79951a35c0457c8a9c9770e9c78" region="cpu2" offset="0"/>
    		<rom name="dd2.02" size="131072" crc="117a3824" sha1="14f3a12170b601c5466c93af9d2f24e0b386b4e4" region="cpu2" offset="28000"/>
    		<rom name="dd2.11m" size="2097152" crc="98d0c325" sha1="7406e8d943d77c468eb418c4113261f4ab973bbf" region="sound1" offset="0"/>
    		<rom name="dd2.12m" size="2097152" crc="5ea2e7fa" sha1="0e6a9fd007f637adcb2226c902394f07de45e803" region="sound1" offset="200000"/>
    		<chip type="cpu" name="68000" clock="11800000"/>
    		<chip type="cpu" name="Z80" clock="8000000"/>
    		<chip type="audio" name="Q-Sound" clock="4000000"/>
    		<video screen="raster" orientation="horizontal" width="384" height="224" aspectx="4" aspecty="3" refresh="59.633331"/>
    		<sound channels="2"/>
    		<input players="4" control="joy8way" buttons="4" coins="4" service="yes"/>
    		<driver status="good" emulation="good" color="good" sound="good" graphic="good" savestate="unsupported" palettesize="4096"/>

    …so if your downloaded romset does not contain these files, it is incomplete and would fail a scanner check in clrmamepro.

    my suggestion is to always download complete sets for the romset your emulator requires (in this case MAME 0.106), and if you’re not confident they are right, run them through a complete scan in clrmamepro. there are no ‘complete’ mame/fba romsets – each are tied to a specific mame/fba version, as are the emulators. you need a matching pair.

    Post count: 5

    YEs, I know about this with mame roms. With every update some roms become unnecessary. The previous rom I had, without those files, work in latest mame versions.

    So, about the shaders.. can anyone tell me how can I put one on for every emu? One that works alright for all… or at least the line to put on all/retroarch.cfg to active it?

    Post count: 15

    Anything on how to tweet the snes emulator so it can be played so smooth??

    Post count: 1828

    You already have a post on another thread for your problem – please stick to one thread. thanks.

    Post count: 8

    Hello everyone!

    I am a new user in this raspi-wotld, and last week I had my raspi2. I have problems with the games related to Port. When I execute Super Mario Wars or Duke Nukem 3D, my controller doest work, the game is stopped in the main menu but it is not frozen. This problem appers always in the Port games.

    My controller is a SNES USB working find with all roms.

    Thank you!!!

    Post count: 1858

    You really should open a new topic for new issues.

    But the problem is you need a keyboard to set up joystick configs.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.