Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • retroresolution
    Participant
    Post count: 25

    Hi everyone,

    short version: The standalone Kodi menu within Emulation Station is present on some builds, not on others (appears only in Ports), using same hardware and images

    I have Kodi installed via the Experimental option on the Retropie-setup menu. I’m getting different results each time I setup an installation on my Pi 3 (I’ve done this several times for various reasons). Once Kodi appeared as a standalone menu, but most times it appears only under Ports.

    The following wiki page contains a custom kodi.sh script to achieve what I want, but one of the comments notes that it is no longer needed, and I’ve seen it work without needing any manual intervention – very odd:
    https://github.com/retropie/retropie-setup/wiki/kodi

    All installations have been performed on:
    Raspberry Pi 3
    Raspbian Jesse (image from Raspbian.org – not Lite or Noobs)
    updated and upgraded via apt-get
    RetroPie 3.6 – installation via github; binaries; updated to latest retropie-setup script

    Prior Attempts and Unsuccessful Changes I’ve made:

    – When I first installed Kodi via the Retropie menu (about 2 weeks ago), it appeared under the Ports menu, and ran fine. The base Raspbian image was 26/2/2016

    – I created a new installation on a larger SD Card (about 1 week ago); this time when I installed Kodi it appeared as a standalone menu entry. I assumed that there’d been some minor change, liked it, and thought no more of it.

    – Last night I broke Raspbian’s desktop, and decided to reinstalled from scratch. Using a slightly newer Raspbian Jessie (18-03-2016), I repeated all steps as before, but found Kodi back under the Ports menu.

    – I tried removing Kodi, installing Kodi from the command line, and by launching the RetroPie-Setup tool within Emulation Station. I was unable to produce the standalone Kodi menu

    – I got the same result when I again wiped the SD Card and repeated everything, ensuring I launched Emulation Station at least once before rebooting and using the Experimental menu option to install Kodi. Again the Kodi entry was only under the Ports section

    I tried adding an <system> entry into /etc/emulationstation/es_systems.cfg, using the values from the (now outdated, apparently) script found here: https://github.com/retropie/retropie-setup/wiki/kodi

    e.g.
    <system>
    <name>kodi</name>
    <fullname>Kodi</fullname>
    <path>/home/pi/RetroPie/roms/kodi</path>
    <extension>.sh .SH</extension>
    <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ kodi %ROM%</command>
    <platform>pc</platform>
    <theme>kodi</theme>
    </system>

    I also tried creating a folder in:
    /home/pi/RetroPie/roms
    and placed a dummy file in there (as Emulation Station tends to hide menus for systems with no roms)

    None of this had the desired effect – I still have no standalone Kodi menu.

    Can anybody enlighten me?
    Thanks

    zerojay
    Participant
    Post count: 173

    It was pulled recently from the builds because it could cause EmulationStation to crash hard and easily. So more recent updates have it removed.

    retroresolution
    Participant
    Post count: 25

    Thanks for confirming that Zerojay, I thought I was going slightly insane there for a while!

    herbfargus
    Member
    Post count: 1858

    You can always follow github to learn what’s changing and why:

    https://github.com/RetroPie/RetroPie-Setup/commit/529489582660abffba157d01795a4f1c99fc87d7

    retroresolution
    Participant
    Post count: 25

    Thanks herbfargus. Not sure why I didn’t think of that until sometime after my original post – I use github anyway!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.