Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • Travis
    Guest
    Post count: 908

    To Anyone:

    I haven’t been able to get my SRAM files to save. When I cleanly exit the emulator (with select/start on my USB gamepad), I get an error in saving the state and it writes to a recovery file instead. I have tried manipulating the retroarch.cfg to force it to a specifice savefile_directory and it still got the same error. I’m at a loss. Any ideas?

    twgillison
    Participant
    Post count: 3

    Well, I have some additional information on this. After trying some configuration file manipulation, I finally decided to just try deleting an srm file to see if it would create a new one. It did…so, for some reason, all my backed up save files (I had recently formatted my SD card and started over with RetroPie) are not being overwritten. So, either they have a lock on them, or the emulator just doesn’t like the file. I’m thinking I can probably rename them .old while the game is in progress and force a new save upon exiting.

    twgillison
    Participant
    Post count: 3

    That works. So, if anyone runs into this, run the game (it appears to load the save file just fine) and while the game is in progress, rename your old srm file (just in case) and then cleanly exit. It will create a new one, and you should be good.

    zatenzu
    Guest
    Post count: 908

    I have this problem. I’ll try to rename my srm file.
    Can you tell me where it’s located?

    twgillison
    Participant
    Post count: 3

    In this case, the files are located in the SNES folder where all of the emulators are listed (/home/pi/RetroPie/emulators).

    Floob
    Member
    Post count: 1629

    Theres a chance this is a permission issue. Make sure user ‘pi’ has rights to write to the roms folder itself.

    I’ve got a bit of info here:

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.