Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • motorhead
    Participant
    Post count: 65

    Hi!

    Im having troubles finding the best audio configuration for each emulator, Im using this configuration for most of them:

    /home/pi/RetroPie/configs/all/retroarch.cfg:

    audio_enable = true
    audio_out_rate = 44100
    audio_driver = sdl
    audio_sync = true

    For NES and Megadrive works great, for SNES seems to work ok, except in some games, but for MAME…

    I tried sdl, alsa and other drivers listed on retroarch.cfg with different rates, but with ones it has no sound, with others games run great but the sound its not fully working, and others make games run slow… Can someone help me with this? It will be great to have a list with better audio configs for each emulator.

    Thanks!

    kitchuk
    Participant
    Post count: 207

    Some mame games won’t have sound as they need extra sound files (samples). Also the retroarch mame emulator is not that good I would recommended pi-mame instead.

    Sent from my GT-I9300

    motorhead
    Participant
    Post count: 65

    Hi!

    This overclock settings worked for me:

    arm_freq=1000
    gpu_mem=384
    avoid_safe_mode=1
    core_freq=500
    sdram_freq=500
    over_voltage=4
    force_turbo=0

    Sound on snes games its perfect now, and Mame runs great too!!

    masterehm
    Participant
    Post count: 14

    @motorhead: Work the overlock setting for you without freezes? Do you use a heatsink for your raspberry pi?

    If I use those settings, my raspberry pi freezes in emulationstation.

    motorhead
    Participant
    Post count: 65

    Hi! This overclock settings are working like a charm! My Pi has heatsink now, but I installed it last week, the rest of time was working without it, without freezes and the games are working great! The only issue that I have it’s sound…

    If you use an standard overclock setting from raspi-config works?? Try using standard 1000Mhz configuration and if it works maybe overheating is not your problem.

    If it keeps freezing, try lower configs midifying core_freq=500 by hand, it makes the difference.

    masterehm
    Participant
    Post count: 14

    Yepp, thats true, core_freq makes the difference. My settings:

    arm_freq=1000
    gpu_mem=384
    core_freq=450
    sdram_freq=500
    over_voltage=6
    avoid_safe_mode=1
    force_turbo=0
    

    And what sound Problems do you have after overclocking? A crackling on some games?

    motorhead
    Participant
    Post count: 65

    Yes, music has some strange noise, but FX seems to be working ok, and games run full speed…

    masterehm
    Participant
    Post count: 14

    To play safe, what do you mean with “FX seems to be working ok”? Do you mean the special effects / graphics or do you mean games with a super fx chip [1]?

    And basically, what are your experiences with super fx games, e.g. Star Fox? Are they playable?

    [1] http://en.wikipedia.org/wiki/Super_fx

    motorhead
    Participant
    Post count: 65

    Hi! With FX sounds I mean special effects, not Super FX games. It’s the music what has crappy sounds. SNES, NES, MAME and SEGA ones are perfectly running, but is FBA which has that strange noise.

    RetroMarine
    Participant
    Post count: 153

    Will these settings fix psx games? I’m trying to play crash bandicoot games and they all run like shit. How do I change to these settings, since they’re not options from the sudo raspi-config menu?

    motorhead
    Participant
    Post count: 65

    Hi! You need to write it manually.

    For all emulators:
    /home/pi/RetroPie/configs/all/retroarch.cfg

    If you want that changes only affect a single emulator edit retroarch.cfg in his own directory, and copy the lines from the “all” file:

    /home/pi/RetroPie/configs/snes/retroarch.cfg
    /home/pi/RetroPie/configs/mame/retroarch.cfg

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.