Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • infern0
    Participant
    Post count: 1

    Hello,

    Did some digging around in the forum and was unable to find information related to the issues I am having with my TOMEE Snes USB controller. I am running Rasp Pi B with the latest RetroPie update.

    I am able to use the keyboard to control the menu and roms.

    I am able to use the Snes USB controller to control the menu, but NOT the roms. Once a rom is loaded it simply will not recognize input from the controller. I have tried switching usb ports, no keyboard plugged in, rebooting.

    I hope this is a simple thing to fix! I have read that some other people are using this controller for the RetroPie.

    Please, what should I do?

    Thank you for your time! Much appreciated.

    alexolney
    Participant
    Post count: 3

    You need to register the controller with RetroArch. From the command line type:

    cd RetroPie-Setup
    sudo ./retropie_setup.sh

    You’ll then be taken to a setup screen and you’ll want to select ‘Setup’. From here select ‘Register RetroArch controller’ and you’ll be taken through a similar button mapping setup that you did when you loaded the menu for the first time. For buttons such as L2 and the stick axis just leave the controller alone and one by one they’ll time out.

    Hope that helps :)

    kayemdubs
    Participant
    Post count: 2

    I don’t get the option to map my keys. I get the code below. I am running a B+ on RetroPie 2.3. I am brand new to linux and the pie so I have no idea where to go with this. Any ideas? Thanks.

    /home/pi/RetroPie-Setup/scriptmodules/supplementary/retroarchjoyconfig.sh: line 14: /opt/retropie/emulators/retroarch/retroarch-joyconfig: No such file or directory
    grep: /opt/retropie/emulators/retroarch/configs/tempconfig.cfg: No such file or directory
    mv: cannot stat `/opt/retropie/emulators/retroarch/configs/tempconfig.cfg’: No such file or directory
    chown: cannot access `/opt/retropie/emulators/retroarch/configs’: No such file or directory

    Floob
    Member
    Post count: 1629

    If that is a new install, I would be tempted to use 2.6.0 and try again.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.