Viewing 1 post (of 1 total)
  • Author
  • doxelnaut
    Post count: 1

    I have successfully setup and used my GPIO adapter with a Raspberry Pi B+. However, I recently upgraded to a Raspberry Pi 2 B and am having little success getting any input from my controllers.

    Image: RaspberryPi 2 V.3 Beta 2
    GPIO Adapter: V.1.2
    Controllers: Original SuperNintendo Controllers

    What I have done to get here:
    1.Flashed image to sd card – boots and runs fine.
    2.Ran through all setup including installing GPIO drivers (Selected Revision 1.X, tried with polling only pads and with polling button and pads).
    3.Made sure SNESDev is running.
    4.Tried to use jstest on both detected controllers

    Once I fire jstest I get no input, the axis values are stuck at their default values and won’t change and no button input is detected.

    I have tried connecting everything to my old pi (raspberry Pi B+) using a microsd card to standard sd card adapter, and everything worked great; by this I mean jstest successfully detected controller input for both controllers (I did not try the emulators as this image is for a Raspberry Pi 2 and figured it may cause issues).

    So I know my GPIO adapter is working, and that the software seems to be functioning ok (at least on the older Pi). I figured it must have been the raspberry pi 2 and took it back and exchanged it for another. I am now having the exact same issue with this new PI 2 B.

    Does anyone have any ideas where I should go from here?

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.