Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • Anonymous
    Post count: 1

    Has anyone had any success getting the PS3 ShanWan Controller registered via bluetooth? It works well when connected via USB, but the standard process using sixpair and sixad, does not allow it connect.

    I’ve tried the the yarick123 fork of qtsixa and tried changing the GASIA_GAMEPAD_HACKS = true setting in the qtsixa Makefile as suggested by one post.

    I know there is a solution, since I can get this exact setup to work out of the box with recalboxOS.

    Post count: 9

    Hi, you could put to work the Shanwan Bluetooth controller?

    Post count: 5

    Here is my ‘hacked’ version of the sixad driver to work with Shanwan/other knock off controllers. The controllers don’t seem to support certain bluetooth/sdp responses like the Sony controllers do. This works around the issue.

    I also disabled the accelerometers/gyro to help with the ‘noise’ of setting up controllers/etc. I don’t use any of that function but you can enable it again by editing the sixaxis.cpp file, remove the area where I commented it out.

    To make/install
    download attachment, save on your pi
    tar xfvz ps3controller.tar.gz
    go into the ps3controller/sixad folder
    do a make
    sudo service sixad stop
    sudo make install
    sudo service sixad start

    This works for me, your mileage may vary. I also added a call to hciconfig hci0 piscan after adding a controller so you can use more than one controller. At this time I’ve tested it with two controllers (both a mix of a shanwan and a sony, and two shanwan controllers).

    FYI, I don’t know bluetooth, this was a lot of trial/error to make things work for me. Your mileage may vary. I also added a lot of debug messages, so check out /var/log/sixad to help in any troubleshooting.

    note – I also tried updating bluez to the latest version to work with the Shanwan controllers. Unfortunately for me that didn’t work either because of the SDP requirement, though it worked nicely with the Sony PS3 controllers.

    * Updated Link. Hopefully this works.

    Post count: 5

    I don’t know the best way to share the file, I couldn’t attach it. The link above is no longer valid/links to the wrong file now.

    If someone needs it, message me. If someone wants to give me a clue as to how to share, let me know.

    Updated the link above, but here it is again to download

    Post count: 1

    I was able to download the attachment, save it on my pi, unzip the file, and do a make but I can’t figure out the step ‘service stop sixad’.

    I must not be typing it in the command line right or I might not be in the right directory. I have absolutely no knowledge of Linux or programming so I really need things spelled out for me.

    Post count: 5


    My directions are flawed, it should be:
    sudo service sixad stop

    sudo service sixad start

    My mistake. I fixed it up above.

    Post count: 7

    Oh, you brought me hope and I thought I could finally use my knockoff ps3 controller wirelessly… but no, even with your version of sixad, I cannot pair it.

    I copypaste you the hci info in case you wanted to check it:

    pi@retropie /var/lib/sixad/profiles $ hcidump
    HCI sniffer - Bluetooth packet analyzer ver 2.4
    device: hci0 snap_len: 1028 filter: 0xffffffff
    > HCI Event: Connect Request (0x04) plen 10
        bdaddr 00:1E:3D:DE:41:02 class 0x001f00 type ACL
    > HCI Event: Command Status (0x0f) plen 4
        Accept Connection Request (0x01|0x0009) status 0x00 ncmd 1
    > HCI Event: Connect Complete (0x03) plen 11
        status 0x00 handle 42 bdaddr 00:1E:3D:DE:41:02 type ACL encrypt 0x00
    > HCI Event: Command Status (0x0f) plen 4
        Read Remote Supported Features (0x01|0x001b) status 0x00 ncmd 1
    > HCI Event: Read Remote Supported Features (0x0b) plen 11
        status 0x00 handle 42
        Features: 0xfc 0x07 0x82 0x7a 0x08 0x18 0x00 0x80
    > HCI Event: Command Status (0x0f) plen 4
        Remote Name Request (0x01|0x0019) status 0x00 ncmd 1
    > HCI Event: Remote Name Req Complete (0x07) plen 255
        status 0x00 bdaddr 00:1E:3D:DE:41:02 name 'PLAYSTATION(R)3Conteroller-ghic'
    > HCI Event: Disconn Complete (0x05) plen 4
        status 0x00 handle 42 reason 0x13
        Reason: Remote User Terminated Connection

    And nothing happens. I’ll keep using my controller with a cable :´(

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.