Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • stereopi
    Post count: 3

    Hi everyone, hope you’re all well!

    I got my Raspberry Pi in the beginning of this week so I am new to all this. I chose the RetroPie as my first project and have been playing around with it for a couple of days now.

    Even tho there is a huge amount of info on this forum (thank you everyone) and elsewhere around the web, I am still having struggles setting everything up properly / the way I want things.
    I have watched and read about every singe tutorial/guide I’ve found on the web but even with all these tips things are not quite right.

    Setup: Raspberry Pi B+ (700MHz Processor, 512MB RAM, 4x USB Port)
    8Gb Micro SD
    32Gb USB Flash Drive

    Using HDMI with ‘Sony Bravia’ 32″. Audio is also going through HDMI

    I downloaded the latest RetroPie IMG (2.3) from the site and burnt it on my 8Gb SD card successfully, loaded the card in the Pi and turned it on.
    After the boot (when it asks you to set your controls for EmulationStation) I hit ALT F4 to get into the console as suggested, to first set up your pi.


    I performed ‘sudo raspi-config‘ to access the set up menu.
    In this menu I did what people advised: ‘Expand File System’ and REBOOT.
    ‘Advanced Options’ split memory 256
    ‘Overclock’ set this to ‘medium’ (9000Hz)

    After this I performed ‘sudo ./’.
    In tis menu I also did what people advised: ‘UPDATE Retropie Setup Script’
    ‘UPDATE Retropie Binaries’
    Rebooted at the end.

    After the reboot I get to the EmulationStation control set up, finish it and continue to EmulationStation.

    Even after the updates, configurations and overclocking, the Pi isn’t really performing well (yet). I was wondering if you guys could help me out with these issues.

    -First visible problem is the resolution or overscan. The EmulationStation menu is too large and some of the information doesn’t fit on screen.
    I’ve tried a few things to fix this (for example ‘sudo nano /boot/config.txt’) but
    I’ve not yet found a solution.

    -I enter the SNES emulator and see that all my ROMS (Saved on my 32GB USB stick) are there in the menu. I played a few games for an hour or so and it seemed to work
    alright. The sound was glitching a lot, slowing down and distorting.

    I read about some people fixing this buy installing the PISNES emulator instead of the RetroArch so I decided to try it.
    I downloaded and installed the PISNES from ‘’, and as people were saying tried to edit the ‘es_systems.cfg’ to run PISNES instead of RetroArch.

    I was struggling with this a lot and finally THOUGHT I got it to work. Entered the EmulationStation and all my SNES games were gone from the list. So I dragged one of my ROMS from my usb stick to the ‘snes-pisnes’ folder on the SD card and it popped up in the emulator, but didn’t work.
    When I ran the game it said : ‘sh: 1: /opt/retropie/emulators/pisnes/snes0x: not found.
    I suppose the route is incorrect but I haven’t figured out how to change this.

    How could I fix this? And also how could I access the SNES ROM’s from my USB drive rather than the SD. I tried making a folder called snes-pisnes (identical to the name on the SD Card) for my ROMS on the usb but this didn’t work.

    All the other systems find the ROMS from the USB without issues.

    Even after the updates, configurations and overclocking, the Pi isn’t really performing well (yet). I was wondering if you guys could help me out with these issues.

    -The games lag a little, especially the sound which is a disaster on the NES and SNES.

    – All the games in my emulators are listed twice, like this:
    ._Mario Bros.
    ._Mario’s Time Machine
    ._Mega Man
    Mario Bros.
    Mario’s Time Machine
    Mega Man

    Very annoying, any of you had the same issue?

    Apologies for the long post but I wanted to try and include as much info as possible to make this a tad easier.
    Any of you guys had similar issues and how did you get around them?

    Thank you guys so much in advance!


    Post count: 71

    I picked up a heat sync and over clocked to 1000, and all the snes games I played worked at normal speed with no sound glitches…

    Granted, the games I tried consisted of Super Metroid, Super Metroid and Super Metroid (Plus a couple Super Metroid hacks)…

    I picked up the heat sync pack off Amazon for about $5… I’m not 100% certain it was needed at 1000, but I figured it couldn’t hurt…

    Post count: 3

    I’ve been considering heatsinks too.

    I’ll try finishing up and setting up the project first, and as finishing touches go I might get the heatsinks.

    I saw someone installed a heatsink with a mini fan, quirky touch!

    Thanks for the response

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.