Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • ejdodd
    Post count: 1

    A Detailed guild to installing Basilisk II (BasiliskII), and actually getting it to work, on your Raspberry Pi.

    So the problem is you don’t know anything about linux, or command lines, and you don’t have time to read 600 volumes explaining Bash. To make matters worse it turns out the approximately 114 online guides all have several inaccuracies, bad links, evil spirits, or ambiguous commands. So after reading approximately half of the internet and every Linux forum page published since 1992 I have discovered in just 3 short days (actually it was 56 hours not including bathroom breaks) how to successfully install Basilisk II on your raspberry pi. Here is as detailed a guild as I could muster:

    Before I being you should know these things:

    1. I use macintosh computers so if you’re on a windows machine you’ll have to figure some stuff out own your own. (but not that much)

    2. I am using a RaspberryPi (B+) model with RetroPie 3.4.something or other OS.

    3. And as far as I’m concerned whoever invented the command line can go shove a full sized computer keyboard up their [*censored by the moderator*].

    4. After you type in the command, hit return/enter.

    5. Everything you need to actually type will be in bold.

    6. The commands are case sensitive.

    Hit F4 to leave RetroPie and find yourself staring into the bottomless blackness that is Linux.

    Type: ls
    You should see “RetroPie-Setup”

    Type: cd RetroPie-Setup

    Type: ls
    You should see “scriptmodules”

    Type cd scriptmodules

    Type: ls

    You should see “emulators”

    Type: cd emulators

    Type: ls
    and a bunch of preinstalled emulators will show up. (including a gray file, ignore this, it’s the computational equivalent of a harpy I think.

    Now you should have the following command line in front of you:
    pi@retropie:~/RetroPie-Setup/scriptmodules/emulators $
    (I know you could just type the whole thing in, but I was worried updates would change the structure of the files so I wanted to show people what they were looking for and how to do it.)

    Type: git clone git://

    Type: cd macemu/BasiliskII/src/Unix

    Type ./

    Type in the following voodoo code:

    ./configure –enable-sdl-video –enable-sdl-audio –disable-vosf –disable-jit-compiler

    (make sure the following words start with two dashes: enable, enable, disable, disable. Apparently some web sights convert two dash symbols into one long dash symbol to make your life suck)

    Now type: make


    Type: sudo make install

    Despite what you might have read from other less… “helpful” instructions, Basilisk II is not ready to run yet.

    You need two files (only two). You need a file called “MacStartup.img” and a file called “Performa.rom”. Because of litigation trolls, and the fact that all of these old decrepit websites keep changing hands from time to time, I will not post hotlinks. You will need to search out these two files on your own. I used a powerful search engine whose colorful name rhymes with “mew gull”. If you were born in a country that has telephones then you have heard of this search engine and their many side projects. I typed the file names into the search bar one at a time. There were found quickly and both were towards the top of the search.

    Remember the files MUST be:

    If you end up with anything else you got hoodwinked by some webpage last updated in 1995. (maybe other roms work too, but if it wasn’t the Performa ROM, I couldn’t get it to work.)

    Now, change the names of these files:
    MacStartup.img becomes disk.img
    And Performa.rom becomes mac.rom

    Got it? You now have two files named disk.img and mac.rom. Find this file path on your pi

    (Use the cd command, ie: cd RetroPie/roms/macintosh)

    Stick those two files into the “macintosh” folder.

    There are probably a billion different ways to do this but I did it by opening my file browser window on my mac and under the “shared” column I Selected the raspberry pi. Hit the “connect as…” button in the top corner. (user name; pi password; raspberry) then I was able to navigate to the said folders like a simple mortal would. There are other ways. Like using thumb drives and terminal commands, or probably downloading the files straight from the internet to the roms/macintosh folder… but I don’t know any commands other than reboot, cd, and ls, so your best bet is to use a mac, if you cant figure out the processes yourself and you don’t own a mac, find some young hip looking graphics designer and explain to them you need to borrow their computer. Tell them you need it to draw a font or something, they can’t resist new fonts.

    Ok now that the files are in the “macintosh” folder type the command:
    sudo reboot

    After your pi has booted up you should see the RetroPie program: Emulation Station.

    Navigate to the image of your “Macintosh” emulator and you should see a “start” option. DONE! Should fire up! (I hope.) It worked for me, and I tried to remember all the steps that actually worked, which is hard because I had to flash my micro sd card about 6 times…

    I don’t know how to get games on there. I don’t know how to get the emulation on the internet. I don’t know how to do anything yet. But hopefully this does for you what the other guides didn’t do for me.

    Basilisk II has made my love life is better, caused most of my hair has grown back, and made me more confident speaking in public, that said I still would not do this all over again if I knew the linux kernel based version of hell I was in for. I hope my guide helps you avoid all that. If I forgot something please post it to the comments. First Post, go easy on me.

    Post count: 63

    From what I can tell, there should be no need download and compile the Basilisk program into RetroPie, it is already included in the version 3.4 you said you’re using.

    Following the RetroPie wiki, I also found the performa.rom/MacStartup.img files, renamed them accordingly to disk.img/mac.rom, placed them in the proper folder, and the emulator boots up no problem.

    The first problem I found is that the disk.img file only has a few MB free when its loaded in the emulator as your hard drive. I had to install Basilisk on my PC in order to have the settings GUI to create a new larger disk image and then copy the contents of the old image to it in order to have a hard drive large enough to do anything in the RetroPie Basilisk.

    After all that, the couple of programs I’ve tried didn’t have any sound, and the mouse is so jumpy it’s not really worth using anyway.

    I’ve read in other forums that people are having much better luck using MinivMac on the Raspberry Pi. It emulates an older version mac without color, but supposedly the compatibility is a little better. Might be something worth looking into adding to RetroPie.

    Post count: 1858

    Link for reference:

    BTW @benwlson feel free to add a short tutorial on the wiki page about sorting out the larger image.

    Post count: 1827

    you can adjust the frameskip for a smoother mouse. I think by default it has a frameskip of 3 or so.

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.