Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • ln_willo
    Participant
    Post count: 3

    Hi people, hoping someone has come across this problem and knows the solution to it. I’ve tried running RetroPie 1.5 and 1.6 beta and all features work perfectly except Sega Master System roms.

    When I try to open a rom (I’ve tried about 10 different ones – all with the same result), it display a screen of code for a second or two before going back to the roms list. When I try it a second time, it goes to a black screen and stops responding. I’ve tried pressing F4 after the first attempt to see the code, but when I press F4 it goes to a black screen as well.

    Does anyone have any suggestions about what might be causing this or how to fix it? I connect via HDMI.

    Thanks
    Luke

    Idris_Arslanian
    Participant
    Post count: 21

    I had the same issue. Solved it by going into the EmulationStation es_systems.cfg and editing the COMMAND portion for Master System, removing the “-tv” (option that forces the emulator into old-school tube mode).

    ln_willo
    Participant
    Post count: 3

    Hi Idris,

    Thanks for the reply. I tried this, but unfortunately I still have the same issue. I also tried connecting via a composite cable instead of HDMI and it had the same problem. Can you think of anything else that might be causing this, or is there some way for me to update the SMS emulator?

    Thanks
    Luke

    karloss
    Participant
    Post count: 177

    you can update by running the RetroPie script and doing a Source install of the sega master system emulator..

    ln_willo
    Participant
    Post count: 3

    Hi Idris,
    I tried a couple more things, I removed all the command switches from after the osmose command. In the end it was the -joy that was causing the fault. I haven’t configured a controller yet, so maybe that is the problem. Thank you for the assistance… I would never have looked there otherwise.
    Thanks
    Luke

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.