Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • trixster
    Participant
    Post count: 76

    Hi all,

    Is anyone else getting problems with quake3 on the rpi3? And with mupen64plus

    With Quake3 it will often freeze when loading levels (getting as far as ‘awaiting snapshot’ on the level loading screen). Sometimes it will get into a level and then freeze after a few seconds.

    I’ve tried the binary and I’ve tried rebuilding from source. I’m using the latest 3.6 retropie and gpu men is set at 320mb.

    Mupen64 is similar – goldeneye freezes at the intro, mariokart 64 will sometimes load, sometimes it will hang on loading with a white screen.

    This freezing behaviour happens regardless of overclock settings. That is to say, it will still freeze whether I’m using stock rpi3 clock settings or whether I’m overclocking. I have a heatsink on my soc.

    Any ideas?

    Swampy
    Participant
    Post count: 16

    Same problem with mariokart 64. Sometimes freezing after the nintendo logo with a white screen. I also had the problem with the rpi2.

    trixster
    Participant
    Post count: 76

    I think it’s a memory issue. It turns out that I was actually using only 256mb for the gpu, not 320 as I thought. Bumping it up to 320 allows quake 3 to run. Mario kart and zelda will now run too. Goldeneye still freezes on the intro so perhaps more memory is required. I counted that I have over 20 systems now running in Emulationstation so perhaps that’s why a 256mb and even a 320mb split is not quite enough…

    trixster
    Participant
    Post count: 76

    Update on this – running at 720p was the issue. Changing up to 1080p (50 or 60hz) or down to 640×480 stopped the crashing in both Quake 3 and mupen64plus. Bizarre.

    Any ideas why 720p might cause these lock-ups?

    Swampy
    Participant
    Post count: 16

    I still have the problem. I also thought it would be something with the resolution. I still have a CRT-TV. Sometimes it worked by changing mupen64plus.cfg, but the next time the error comes again. The mupen64plus.cfg will always be overwritten. Why?

    Swampy
    Participant
    Post count: 16

    I changed the gles2n64.conf and now it seems to work:

    #gles2n64 Graphics Plugin for N64
    #by Orkin / glN64 developers and Adventus.
    config version=2
    
    #Window Settings:
    window width=702
    window height=576
    multisampling=0
    auto resolution=0
    
    #Framebuffer Settings:
    framebuffer bilinear=0
    framebuffer width=702
    framebuffer height=576
    
    #VI Settings:
    video force=0
    video width=702
    video height=576
    video stretch=0
    
    #Render Settings:
    enable fog=1
    enable primitive z=1
    enable lighting=1
    enable alpha test=1
    enable clipping=0
    enable face culling=1
    enable noise=0
    
    #Texture Settings:
    texture 2xSAI=0
    texture force bilinear=0
    texture max anisotropy=0
    texture use IA=0
    texture fast CRC=1
    texture pow2=1
    
    #Frame skip:
    auto frameskip=1
    target FPS=20
    frame render rate=1
    vertical sync=0
    
    #Other Settings:
    update mode=1
    print FPS=0
    ignore offscreen rendering=0
    force screen clear=0
    flip vertical=0
    tribuffer opt=1
    
    #Hack Settings:
    hack banjo tooie=0
    hack zelda=0
    hack alpha=0
    hack z=0
Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.