Homepage Forums RetroPie Project Everything else related to the RetroPie Project Rotating everything by 90 degree

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #7448


    I’m building a “tabletop arcade cabinet” with the Raspberry Pi and as you can guess it uses RetroPie.

    Since, the whole cabinet would be too wide, if I would use it “normally”, so I decided to use it vertically.

    Then came some unexpected problems.

    So, first I tried the normal “display_rotate = 1” line, in the config.txt
    First I tested it via RCA, it worked pretty good, everything was flipped and worked good, but I’m using the monitor with an HDMI => VGA adapter (I still have no idea how, but the adapter works pretty good)
    Aand, with HDMI, console was flipped, emulationstation was flipped, but not a single emulator wanted to start. I still have no idea why.

    Then I heard about the display rotate function in the retroarch.cfg
    First, I tried it with the “display_rotate = 1” commented out, so console wasn’t flipped, and unfortunately EmulationStation wasn’t flipped, but that was pretty much expected. And then came, the miracle, most of the emulators worked, and they were flipped, however I couldn’t get the following emulators working in flipped mode:
    – Gameboy Advance, with gpSP, but actually works without lag, which I didn’t see in previous versions.
    – MAME
    – Sega GameGear, with OsmOse
    – PC (x86), so rpix86

    So basicly what doesn’t run from RetroArch. (Also I haven’t tested Atari 800, Amiga, C64, Intellivision, Basiliskii, ScummVM, ZMachine, ZXSpectrum and FBA)

    Then since, this is a mostly working solution but has some problems, I decided to try out the 2 combined, so with “display_rotate = 1” and also the RetroArch rotation set up, so what doesn’t runs rotated via RetroArch, will may run with the raspberry settings rotated. Unfortunately the results were the same as the first try, console, emulationstation were running rotated, but none of the emulators worked (so black screen).

    Any solutions, suggestions to the problem, so I can run everything rotated by 90 degree, including EmulationStation, console, and also the other emulators?


    I believe the raspberry pi setting for screen rotation is for the terminal and the x desktop gui.

    It could be that the emulators that aren’t rotated have separate configuration files, but osmose seems to use the retroarch.cfg

    Maybe its something to do with the GLSL shader? If you open the additional config file for the master system (/home/pi/RetroPie/configs/mastersystem/retroarch.cfg) then you can see that it has video_shader_enable = true. Maybe setting this to false could work.

    It may be that it’s not supported by certain emulators, which would require additional code.

    A fix all solution would be to obtain a hardware solution, though it would be super expensive.

    I’ll do some testing and see what I can find out.


    Just did some testing,
    Set screen rotation to 1 in rpi config file, and screen rotation to 1 in retroarch.

    Tried sega game gear (using osmose) and it worked first time.


    So I’ve tried MegaDrive which uses the picodrive emulator.
    With the same settings as before (both boot.cfg and retroarch.cfg set to rotation=1)

    The emulator runs but the image is standard orientation, I have enabled FPS in retro arch, and this was actually rotated, so the retroarch overlay rotates fine but the emulator runs in the default orientation.

    I turned off shaders, same thing no orientation in picodrive. I tried to run DGEN emulator and the emulator wouldn’t load correctly.

    I think this might be something to do with supported resolution modes of the monitor and the emulator.

    If you want to know what modes are supported have a look at this – http://elinux.org/RPiconfig

    Which values are valid for my monitor?
    Your HDMI monitor may support only a limited set of formats. To find out which formats are supported, use the following method.

    Set the output format to VGA 60 Hz (hdmi_group=1 hdmi_mode=1) and boot up the Raspberry Pi
    Enter the following command to give a list of CEA supported modes
    /opt/vc/bin/tvservice -m CEA
    Enter the following command to give a list of DMT supported modes
    /opt/vc/bin/tvservice -m DMT
    Enter the following command to show your current state
    /opt/vc/bin/tvservice -s
    Enter the following commands to dump more detailed information from your monitor
    /opt/vc/bin/tvservice -d edid.dat
    /opt/vc/bin/edidparser edid.dat
    The edid.dat should also be provided when troubleshooting problems with the default HDMI mode

    More information available here – http://www.raspberrypi.org/documentation/configuration/config-txt.md



    Thanks for all the testing, and the info you provided.

    They were very, very useful.
    I found it why they don’t work, and probably the solution!

    First, I tried everything with group 2, and mode 1, since I couldn’t get the GG Emulator working even with only config.txt editing (in the original mode, so group 2, mode 35 which is 1280×1024). Then it magically worked. And so did PicoDrive work, exactly as it should, because in the RetroArch config, it is set to rotation 1 (well 3 for my case, because in the RPi config it’s clockwise, and in RA Config it’s counter-clockwise), so it rotates by 90° FROM the rotated 90°, and that results in standard rotation!

    So basicly, if it works with the RPi config’s rotation, then the RA rotation should be set to 0.

    Now I just have to find out which is the highest resolution supported both by the emulators and the monitor, so some testing waits for me, yay!

    Thanks for the help!


    No worries, glad you got it working, so I guess it was the monitor setup.

    Just out of interesting what monitor are you using?


    Well a torn-apart, Fujitsu T19-1. I got it for cheap, and it looks good, and since it’s only a soldered VGA cable, a AC adapter, and the buttons duct taped to back, it’s perfect for building it into a tabletop arcade machine.

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.