Homepage Forums RetroPie Project Video Output on RetroPie Rom-specific ini files in lr-mame2010?


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #118471


    I’m having a terrible time getting a rom (startrek.zip) to load in the correct orientation in lr-mame2010.

    I have created a .cfg to rotate the screen. It is named correctly and placed in the rompath. This .cfg rotates the screen in lr-mame2003, so I know it is set up correctly. I have no clue what else to try to get lr-mame2010 to recognize the .cfg.

    Additionally, runcommand.log shows lr-mame2010 is automatically applying several rotation commands when I run this specific rom.

    value: disabled
    value: disabled
    value: disabled
    SOURCE FILE: src/mame/drivers/segag80v.c
    PARENT: 0
    NAME: startrek
    DESCRIPTION: Star Trek
    YEAR: 1982
    gamePath=/home/pi/RetroPie/roms/arcade gameName=startrek
    startrek “Star Trek” rot=2
    creating frontend… game=startrek
    executing frontend… params:16
    machine screen orientation: HORIZONTAL
    osd init done
    game screen w=480 h=640 rowPixels=480
    osd_exit called
    Retro unload_game
    Retro DeInit

    It appears from the above that lr-mame2010 automatically applies -ror to startrek.zip. The game loads rotated 90 degrees clockwise. I can manually correct the problem in rgui, but I cannot find a way to make the change stick. Does anyone know how to create a custom .ini for a rom? Or how to edit whatever metadata lr-mame2010 is using to create this error? Or even better, how to make lr-mame2010 recognize my existing cfg?

    Thanks everyone.

    Any suggestions would be appreciated.


    read this the configuration overrides section fromhttp://blog.andressm.org/new-retroarch-features-2/

    rgui_config_directory is important. if you look at /opt/retropie/mame-libretro/retroarch.cfg, check that rgui_config_directory is set to your /home/pi/RetroPie/roms/arcade/ folder, and that this where your cfg file is. i imagine it must be as don’t 2003 and 2010 use the same retroarch.cfg file??

    as per the other thread you should do these tests with another config setting that you KNOW works from config files in 2010, and is obvious when it’s applied. eg, video_smoothing on/off or something like that. that way you know if your game.zip.cfg is being used and overriding your regular cfg.


    Hey, yes, you are correct that lr-mame2003 and lr-mame2010 use the same retroarch.cfg.

    I went to /opt/retropie/configs/mame-libretro/retroarch.cfg and added “rgui_config_directory = home/pi/RetroPie/roms/arcade/”. I then went into startrek.zip.cfg and added “video_smoothing on”.

    I can see my custom cfg when setting launch options before launching into the game.

    Neither step had any effect in lr-mame2010.

    I should mention that the game runs in the correct orientation by default in lr-mame2003. When I load the game in lr-mame2003, it rotates the game 90 degrees counterclockwise, as per my custom cfg (the same result I want in lr-mame2010). The reason I’m not running it in lr-mame2003 all the tie is that lr-mame2003 doesn’t emulate the sound at all.

    I have no idea why this is happening, save that lr-mame2010 might not be set up to read the custom cfg…


    that’s a thorough test, thanks :)

    so if you put the ‘rotate’ config line in the main /opt/retropie/configs/mame-libretro/retroarch.cfg it applies it in mame2010 and 2003?

    assuming that’s true, it seems like you’ve you’ve ruled out everything exept that mame2010 just isn’t reading the override cfg files. i don’t think this is a retroarch/core issue, as overrides are handled centrally by retroarch (i think) – if that wasn’t working it wouldn’t work in 2003 either. i think it must be something to do with how mame2010 is being launched by retropie (perhaps it’s not got the correct target directory or something like that). i think at this point it’s best logged as an issue here: https://github.com/RetroPie/RetroPie-Setup/issues

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Video Output on RetroPie’ is closed to new topics and replies.