Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • luvien99
    Post count: 2


    I’m trying to install Hyperion on my Rpi with Retropie 3. The problem is after the hyperion installation, the json server is not running and I get “Can’t connect to the host” trying to send command. I tried with Retropie 2.6 same thing.

    I took a nee Sd card, installed OSMC and hyperion and everything is working great.

    Any ideas? Many thanks,


    Post count: 1

    Hi there,

    I have been trying the same thing for the past week and I haven’t gotten anywhere.

    How do you start it? With: sudo hyperiond /etc/hyperion.config.json ?


    Post count: 23

    I was actually going to try getting Hyperion installed/working once i get some other things squared away. If im not mistaken, RetroPie is built on Raspbian. I would try following that wiki first. First thing i would try from an SSH session is “netstat -tnl” to see what ports listening. If you dont see the default open then that would be a place to start. Change the default port in the hyperion config file. I think the default port is 19444 or 19445. You can also alter your iptables to open the port. I think the command to do so is:
    sudo iptables -A INPUT -p tcp –dport 19444 -j ACCEPT
    sudo iptables -A INPUT -p tcp –dport 19445 -j ACCEPT

    Goodluck and I hope its as easy as opening the ports because in the next few days ill be giving it a go too.


    Post count: 2

    Thanks! I will try that today and get back to you.

    Right now I got it working using OSMC and retropie installed on the same SD card. I don’t really need OSMC, but it’s working and I can start Retropie from OSMC GUI.


    Post count: 23

    Hey luvien99,

    Did you get it working? I didnt run into any real problems like you stated above. I did have to install lsb-core and that seemed to fix any of my issues. What i did was:

    sudo apt-get update

    sudo apt-get install libqtcore4 libqtgui4 libqt4-network libusb-1.0-0 ca-certificates

    Enable spi via retropie advanced settings or sudo nano /boot/config.txt and add dtparam=spi=on to the bottom of the file and reboot

    wget -N

    chmod +x
    sudo ./

    hyperion-remote –priority 50 –color red –duration 5000

    dont forget to put your hyperion.config.json file in /etc/ and change the file effects path to the effects folder wherever that installs for you mine was /opt/hyperion/effects which I didnt have to change so i doubt you would

    I still have some tweaking to do but this is what mine is looking like right now:

    Hope that made sense or helps,

    Post count: 6

    i got it to run. with and without grabber.
    but i have to do this command “sudo apt-get –reinstall install upstart” to get it working with grabber. But this command breaks the autologin. Now i must login manually everytime i start. Does anybody know how to start emulationstation instead. i am out of ideas.

    ps. i tried in the raspi-config boot to scratch and in retropie_setup the “boot in emulationstation”

    many thanks

    Post count: 23

    Does it look like its trying to boot then crashes to console? Do you have a debug log?

    Post count: 35

    Please help. I can not install Hyperion on Retropie. I installed according to these instructions:

    Test instalation :

    pi@retropie ~ $ hyperion-remote --priority 50 --color red --duration 5000
    Unable to connect to host

    SPI Enable with Raspi-Config and config.txt


    pi@retropie ~ $ cat /etc/modprobe.d/raspi-blacklist.conf
    # blacklist spi and i2c by default (many users don't need them)
    #blacklist spi-bcm2708
    blacklist i2c-bcm2708
    pi@retropie ~ $ sudo hyperiond /etc/hyperion.config.json
    hyperiond: error while loading shared libraries: cannot open shared object file: No such file or directory

    Ports listening:

    pi@retropie ~ $ netstat -tnl
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp        0      0   *               LISTEN
    tcp        0      0 *               LISTEN
    tcp        0      0   *               LISTEN
    tcp        0      0   *               LISTEN
    tcp        0      0    *               LISTEN
    tcp        0      0 *               LISTEN

    I do not know if this is a problem in the port or at the library
    Some idea? Can you help?

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Everything else related to the RetroPie Project’ is closed to new topics and replies.