Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • rupee990
    Post count: 2

    Hello, I have been working 2 days on this and reinstalled retroppie 2 times.

    Iam trying to run GBA roms, but when I open them it only says the following:

    /opt/retropie/supplementary/runcommand/ line 304: 2406 illegal instruction /opt/retropie/emulators/gpsp/gpsp /home/pi/RetroPie/roms/gba/Pokemon\ -\ Fire\red\ Version\(USA).gba

    I updated my binairies…all my paths in the es_configs are fine..

    Here is the one from etc/emulationstation/es_config.cfg:

    <fullname>Game Boy Advance</fullname>
    <extension>.gba .GBA</extension>
    <command>/opt/retropie/supplementary/runcommand/ 1 “/opt/retropie/emulators/gpsp/gpsp %ROM%” “gpsp”</command>

    I do not know what to do anymore I have tried everything I found on the web…

    GBAbios: Gba_Bios.bin
    retropie version: v2.6.0-rpi2
    raspberry: raspberry pi 2 B+ ( 1gb Ram; 900Mhz Quad ARm)

    Post count: 2

    I have now tried to Run gpsp from its file

    I went to: /opt/retropie/emulators/gpsp

    and and tried: sudo ./gpsp

    it didnt tell me nothing it just went to a new Entry line.

    Tried to run GBA afterwards and still the illegal instruction error.
    Another thing I have tried is Update my gpsp files.

    but it gives me a following error:

    ../cpu.c:4371:7: warning: variable old_pc set but not used [-Wunused-but-set-variable]

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.