Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • czesiek32
    Participant
    Post count: 22

    Hi there,

    I’ve found issue related to version 3.0 beta 2 for Retropie 2.

    Pi Model: 2B
    RetroPie Version Used: 3.0 Beta 2
    Built From: SD Image
    Controller used: Rertolink SNES controller (worked perfectly with retropie 2.6 / raspberry pi 1 B+)
    How to replicate the problem:

    Keys X and Y are not being recognized in any Retroarch emulator (tested with playstation and n64).

    I run ‘configure retroarch keyboard/joystick’ from ‘retropie’ emulation station menu a few times. Also I rebooted pi after that. No effect – only ‘default’ keys ‘A’ and ‘B’ can be used in games. ‘X’ and ‘Y’ can not be used. Running via command line (sudo ./retropie_setup.sh) takes no effect as well. As I see file /opt/retropie/configs/all/retroarch.cfg is not being altered by this command (I use ls -l to check modification date). I believe that script is not saving it’s result to this file.

    Additional info:

    Previously I was using Retropie 2.6 and 3.0 beta 1 on Raspberry pi B+ and it was working fine (the same gamepad) without any extra configuration (I didn’t even have to configure retroarch controller). I guess this can be related only to Retropie 3.0 beta 2 for Raspberry pi 2.

    If you need more details please let me know, I’m happy to help as much as I can.

    Robert

    czesiek32
    Participant
    Post count: 22

    I found out that mapping I need is:

    User 1 Y button (left): 3
    User 1 X button (top): 0

    Can somebody please tell me where can I set this?

    czesiek32
    Participant
    Post count: 22

    I tried also this:

    cd /opt/retropie/emulators/RetroArch/installdir/bin
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    And /opt/retropie/configs/all/retroarch.cfg was updated but buttons are still not recognised by emulator.

    lurking-klown
    Participant
    Post count: 5

    Hi we are having the exact same problem. If anyone has any idea how to fix this please let us know. It is getting very frustrating!
    I’ve tried reconfiguring the control but when I go into retroarch.cfg none of the buttons are mapped.

    Floob
    Member
    Post count: 1629

    I’d recommend going back to the clean image as you have edited the retroarch.cfg files quite a bit. You could put them back how they were but may well be easier starting again.

    When you configure the retroarch joypad from the menu, it updates the controller file in this directory.

    /opt/retropie/emulators/retroarch/configs

    This is referred to in the main retroarch.cfg file
    /opt/retropie/configs/all/retroarch.cfg in these line

    input_autodetect_enable = true
    joypad_autoconfig_dir = /opt/retropie/emulators/retroarch/configs/

    If you start editing the retroarch.cfg its very easy to screw this up.

    Rule of thumb is if you want auto detection etc.. keep the default truned on.
    If you want to heavily customize the controller for each system, do it in the system config directories, I’d really try to leave retroarch.cfg alone.

    I *think* your joypad is the USB_Gamepad_.cfg file

    This video should help

    You can double check your controller settings with jstest

    lurking-klown
    Participant
    Post count: 5

    Ok so I tried to test it but now when I put the command it instead of taking me to the directory it just puts up the message “/opt/retropie/emulators/retroarch/configure: is a directory”
    So I can’t test the control and can’t get into directories now :/
    Also I did start again with a fresh image so I really don’t know what’s wrong as I am following instructions exactly :(

    Floob
    Member
    Post count: 1629

    What command did you type?

    Change to this directory
    cd /opt/retropie/emulators/retroarch/configs

    then list it with “ls”

    Then you can edit the file with
    “sudo nano insertfilename.cfg”

    The two vids above explain it better.

    czesiek32
    Participant
    Post count: 22

    I believe we should just wait until this bug will be fixed. By now I recommend installing version 2.6 which works just fine.

    Floob
    Member
    Post count: 1629

    [quote=94337]

    Keys X and Y are not being recognized in any Retroarch emulator (tested with playstation and n64).

    [/quote]

    I dont have any N64 or PS1 games to hand, but I just tried this with SNES and Megadrive and it seems fine for me. I’m using an iBuffalo USB joypad.

    lurking-klown
    Participant
    Post count: 5

    K so I finally figured out the directory thing lol.
    I’m 100% sure I have all the correct information in now the jstest showed all the buttons working but still only a + b work in game.

    Is there something I need to turn on?
    Is there something to like enable the file so it runs on all the emulators :/ I thought it was meant to do that automatically but I have obviously missed something.

    Thanks for the help so far.

    Floob
    Member
    Post count: 1629

    When you start a game, do you get yellow text at the bottom of the screen showing you which file it is loading for your controller?

    If you post that file here, it may help us work out why it is ignoring some buttons.

    lurking-klown
    Participant
    Post count: 5

    Joypad port #0 (USB gamepad) configured.

    Floob
    Member
    Post count: 1629

    Ok, in that case, when you run games via retroarch it is processing this file for your controls:

    /opt/retropie/emulators/retroarch/configs/USB_Gamepad_.cfg

    You can read this by typing
    “sudo nano /opt/retropie/emulators/retroarch/configs/USB_Gamepad_.cfg”

    Assuming you havent edited
    /opt/retropie/configs/all/retroarch.cfg or
    /opt/retropie/configs/{systemname}/retroarch.cfg

    then the first file above is how it works out its controls.

    You can check the file matches your controller buttons with jstest

    If it doesnt match, just reconfigure it using the wizard here (or do it manually if you want):
    “sudo /home/pi/RetroPie-Setup/retropie_setup.sh”

    Then choose
    3- Setup
    320 – Configure input devices for RetroArch

    gobbla
    Participant
    Post count: 4

    I have the same problem with the same controller.
    I have tried deleting USBGamepad.cfg and doing the retropie_setup.sh script. It does work in other emulators, but not on SNES games..

    USBGamepad.cfg:
    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_menu_toggle_btn = “0”
    input_load_state_btn = “4”
    input_save_state_btn = “5”
    input_reset_btn = “2”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”

    solareclipse
    Participant
    Post count: 4

    Having the exact same probleme as well. Tried every tipp I could find but nothing helps.

    Thinking about going back to 2.6

    Floob
    Member
    Post count: 1629

    Just a thought – but could you try deleting all files in
    /opt/retropie/emulators/retroarch/configs/

    then try running the controller setup script again – just so you have just the one config file in that dir?

    floww
    Participant
    Post count: 1

    Hi, I was having the same problem but i found a solution!
    This is most certainly a bug.

    Go to the right directory:
    cd /opt/retropie/emulators/retroarch/configs/

    then replace USB_Gamepad_.cfg with USBgamepad.cfg
    So…
    cp USBgamepad.cfg USB_Gamepad_.cfg
    You might want to make a backup first for USB_Gamepad_.cfg

    Hope this helps.

    gobbla
    Participant
    Post count: 4

    [quote=96992]Hi, I was having the same problem but i found a solution!
    This is most certainly a bug.

    Go to the right directory:
    cd /opt/retropie/emulators/retroarch/configs/

    then replace USB_Gamepad_.cfg with USBgamepad.cfg
    So…
    cp USBgamepad.cfg USB_Gamepad_.cfg
    You might want to make a backup first for USB_Gamepad_.cfg

    Hope this helps.

    [/quote]

    This does not work for me. Can you please paste your config? Mine is:

    input_device = “USB Gamepad ”
    input_driver = “udev”
    input_b_btn = “2”
    input_y_btn = “3”
    input_select_btn = “8”
    input_start_btn = “9”
    input_up_axis = “-1”
    input_down_axis = “+1”
    input_left_axis = “-0”
    input_right_axis = “+0”
    input_a_btn = “1”
    input_x_btn = “0”
    input_l_btn = “4”
    input_r_btn = “5”
    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_menu_toggle_btn = “0”
    input_load_state_btn = “4”
    input_save_state_btn = “5”
    input_reset_btn = “2”
    input_state_slot_increase_axis = “+0”
    input_state_slot_decrease_axis = “-0”

    Floob
    Member
    Post count: 1629
    gobbla
    Participant
    Post count: 4

    Thanks Floob. I’ve tried that among with all other stuff my google-fu has given me. One person suggested downgrading the kernel, and that bricked the installation entirely.

    Floob
    Member
    Post count: 1629

    You say it works on all games, but not SNES ones?
    Have you tried a few different SNES games? (And which emulator are you using – a libretro one?)

    If you have tried a few games (and not just Mario All Stars) then presumably there is something odd in (assuming you are using a libretro emulator) /opt/retropie/configs/snes/retroarch.cfg

    gobbla
    Participant
    Post count: 4

    [quote=97215]You say it works on all games, but not SNES ones?
    Have you tried a few different SNES games? (And which emulator are you using – a libretro one?)

    If you have tried a few games (and not just Mario All Stars) then presumably there is something odd in (assuming you are using a libretro emulator) /opt/retropie/configs/snes/retroarch.cfg

    [/quote]

    Yes, its pretty much being used out of the box, so I’m guessing its libretro.

    I have no idea what the culprit really is, but I know alot of people is experiencing the same thing on the newest BETA.

    My retroarch.cfg:

    #include “/opt/retropie/configs/all/retroarch.cfg”
    # All settings made here will override the global settings for the current emul$
    input_remapping_directory = /opt/retropie/configs/snes/
    video_shader = /opt/retropie/emulators/retroarch/shader/snes_phosphor.glslp
    video_shader_enable = false
    video_smooth = false

    Floob
    Member
    Post count: 1629

    When you start a game, press X and choose a libretro emulator (the prefix is lr) then it should be good.

    jdaly82
    Participant
    Post count: 4

    Hi, I’ve been having the same issue too. I have tris replacing the files and re running the setup and have had no resolve to the issue. Both the X and Y buttons are non responsive and I have tried it on multiple games. Anyone getting to close to a solution for this?

    Floob
    Member
    Post count: 1629

    [quote=97405]Hi, I’ve been having the same issue too. I have tris replacing the files and re running the setup and have had no resolve to the issue. Both the X and Y buttons are non responsive and I have tried it on multiple games. Anyone getting to close to a solution for this?

    [/quote]

    Which controller do you have?

    jdaly82
    Participant
    Post count: 4

    So I noticed something today and maybe someone can figure this one out and maybe it can create a solution for this problem. I bought an N64 controller today and noticed that when I played SNES games the X and Y as well as the right and left shoulder buttons worked. So when it loaded I noticed the file name: Generic USB Joystick and went to /opt/retropie/emulators/retroarch/configs to find the file to see how the buttons where programmed, but he file isn’t there in that folder. Anyone have any ideas as to where the file is then? And if so maybe that’s why when I modify USBGamepad.cfg it doesn’t fix the problem on the SNES controller?

    Floob
    Member
    Post count: 1629

    If you are comfortable registering new RetroArch controllers in the setup menu, delete the files here:
    /opt/retropie/emulators/retroarch/configs/

    Then recreate your config file, then it will be very obvious which one it is.
    But regardless the text that appears in yellow when you start a game should show the full filename of the file it loads, can you catch what it is?

    jdaly82
    Participant
    Post count: 4

    Here is a picture of it.

    jdaly82
    Participant
    Post count: 4

    And here is the picture of the files. As you can see the name. That’s on the screen is t in the files listed here

    Floob
    Member
    Post count: 1629

    Does the text scroll off the screen?
    You can set a smaller font by changing this line (set the value to 12):
    video_font_size = 12

    Make sure it doesnt have a # at the start of the line

    Its in this file:
    /opt/retropie/configs/all/retroarch.cfg

    =====================

    Although I think this will solve it:

Viewing 30 posts - 1 through 30 (of 30 total)
  • You must be logged in to reply to this topic.