Homepage Forums RetroPie Project New to RetroPie? Start Here! RetroPie 3.5 gamepad configuration every time on boot

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #117018


    I have Pi Zero with RetroPie 3.5 on 16gb sd card with keyboard, gamepad nad wifi dongle connected through powered usb hub.

    I’ve spent almost whole weekend trying to get it working witout success…

    After installation of RetroPie emulation station is launched and i have to configure gamepad. My gamepad is Esperanza PS3-like controller and it is recognized as “Sun Light PS2 PS3 USB Controller”. During key mapping i have none problems with key assignment.

    Afterwards i press A and go to menu. Now if i select any option like Super Mario or configure wifi and go back to menu gamepad doesn’t work anymore. Keyboard doesn’t work also (arrows or anything besides F4). Then i press F4 and go back to terminal, start emulation station again and i have to configure controller all over again.

    There are many guides with controller configuration but almost everyone refers to 2.X Retropie…


    please can you post the output of this run from terminal (via ssh)
    after configuring the controller in emulationstation

    cat ~/.emulationstation/es_temporaryinput.cfg
    cat ~/.emulationstation/es_log.txt

    please use a site like pastebin.com for the logs.


    es_temporaryinput.cfg: http://pastebin.com/3TCvUiuk

    es_log.txt: http://pastebin.com/BJhARjJG

    I did a clean install once again. After first boot i mapped controller, went to Retropie -> configure WiFi -> connected to WiFi and after i went back to menu weren’t working anymore… Then i did a reboot (F4 was working with keyboard) and had to configure controller again at welcome screen.

    I followed this guide on youtube: https://www.youtube.com/watch?v=AhkEnDdygbQ

    And it didn’t solve my problem but i found out that there is my controllers config saved


    SunLightPS2TOPS3&USB.cfg: http://pastebin.com/q3fGXFPs

    So looks like every time i configure controller again it overwrites previous setup. The question is why controller stops working wheni go back to the menu and why i have to configure it at welcome screen every time…


    It’s to do with the encoded & in the device name – we need some changes our side to fix that.


    So there isn’t any fix for that atm? I did some digging and found out that adding backslash before & sign might work like it helped someone with “/” in his device name:

    USB controller device name has a “/” in it!
    byu/661305 inRetroPie

    Tried changing name with backslash but it did’t work:


    I just fixed it. please do the following from terminal

    cd ~/RetroPie-Setup
    git pull
    rm ~/.emulationstation/es_input.cfg
    sudo ./retropie_packages.sh emulationstation configure

    and then restart and configure your pad.


    Everything is working fine now. Thank You for a lot for quick help!

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘New to RetroPie? Start Here!’ is closed to new topics and replies.