Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • phoenixfox
    Post count: 3

    Hello everyone,

    I’m having issues with this adapter:

    (I have tested it in my Windows machine and works out of the box)

    I have tried to use it with my Retropie 3.0b2 (built from image) setup and EmulationStation won’t detect the SNES gamepad.

    Things I’ve tried so far:
    – Xbox controllers and Playstation2 controllers (with adapter) work
    – Keyboard works
    – I have tried with a fresh install of Retropie 2
    – JSTest recognizes the SNES controller and axis/buttons work

    pi@retropie /dev/input $ jstest js0
    Driver version is 2.1.0.
    Joystick (INNEX SNES Controller USB) has 2 axes (Hat0X, Hat0Y)
    and 12 buttons (BtnX, BtnY, BtnZ, BtnTL, BtnTR, BtnTL2, BtnTR2, BtnSelect, BtnStart, BtnMode, BtnThumbL, BtnThumbR).
    Testing ... (interrupt to exit)

    I have tried some pre-compiled kernels that resolved issues with retrobit controlers with no success.

    I appreciate any suggestions.

    Post count: 36

    Same issue here. Hoping someone can provide an answer. More details below. I don’t know what the “S” lines are, but they’re missing in the non-working SNES adapter. Perhaps that is related to why they are not being recognized by emulationstation or the emulators?

    Post count: 3

    Good luck man… I had to give up and now I’m using Xbox 360 controllers.

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.