Homepage Forums RetroPie Project Controller Configuration in RetroPie Retroarch won't recognize both joystick sets on my ipac2

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #114914

    Hey guys, need some help.
    I have my RAspberry pi 2 set up with retro pie. I have an arcade cabinet that it is in but I cannot get the 2nd set of buttons and directions to function utilizing my ipac2. Now, both sets function individually and I know the keystrokes that correspond to each button. I went into nano sudo /opt/retropie/configs/all/retroarch.cfg from the terminal and went down to the player1 input commands and made an identical set for player2 that corresponded to the keystrokes that the system recognizes in a text editor. I rebooted and restarted but still nothing works from my second set of controls. Everything is saved and I can see the changes I made even after rebooting. I’m using retropie 3.3 and rpi2 and ipac2 and retroarch/emulationstation. Please, if you could point me in the right direction, that. Would. Be. Awesome!



    I’m also running the same setup as you. I programmed and verified the IPAC2 keystrokes in windows. Since I originally booted the retropie with a standard keyboard, it wouldn’t recognize the IPAC2 when connected. So I had to go to controller configuration by hitting the “START” button and then hold any button on the IPAC2 control panel to register the new controller. The only other thing I did after this was modify the retroarch.cfg file and add the following lines under the player1 controls…

    input_player2_a = s
    input_player2_b = a
    input_player2_y = w
    input_player2_x = i
    input_player2_start = num2
    input_player2_select = num6
    input_player2_left = d
    input_player2_right = g
    input_player2_up = t
    input_player2_down = f

    Below are a couple pics of my setup. With a little trial and error I found this configuration to work pretty good right out of the box with most emulators. My 1B button is my exit button and I programmed it as a macro so it has a key combination of (ESC, 5, 1). This will get you out of most emulators that I’ve tried. The only other macro I have is for 1SW7, it is programmed to the keystrokes (E X I T Enter), this will exit the terminal. And hitting 1SW2, 1A, then 1SW2 again will get you into the terminal. This is useful if you are updating rom sets in the retropie and need to refresh the list…. basically enter the terminal and then exit it. I’m a newbie to all this so there may be better methods than what I’ve done.


    That’s exactly what I had tried but it didn’t work. I did figure it out, though. I was hoping altering the retroarch config file would work, but instead I changed the individual config files for the NES and SNES and it worked perfectly. Thanks for the help!!


    Glad you got it working. I didn’t have to make the changes to every emulator. Not sure if there are multiple retroarch.cfg files or not but I changed the one located here… \\PI IP Address\configs\all

    FYI, I also found this link useful for adding “turbo buttons” in the NES….https://github.com/plastygrove/libretro-fceumm

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.