Tagged: ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • superfonzy
    Participant
    Post count: 1

    Hi Guys

    Nearly at wits end with this issue. Trying to get shaders working (for NES in particular). I followed this helpful thread and configured all the retroarch.cfg files I could find with the following settings:

    /opt/retropie/configs/all & /opt/retropie/emulators/RetroArch

    – video_shader = “/opt/retropie/shader/*.glslp”
    – video_shader_enable = true
    – video_shader_dir = /opt/retropie/shader/

    /opt/retropie/configs/nes
    – video_shader = “/opt/retropie/shader/hq2x_phosphor.glslp”
    – video_shader_enable = true

    The issue is when I go to run a NES game I get the following error before the game fires up:

    “Frontend supports RGB565 – will use that instead of XRGB1555”
    “RetroArch [ERROR] :: Failed to load GLSL shader: /home/pi/RetroPie/shader/hq2x.glsl”
    “RetroArch [ERROR] :: Failed to init sharer, falling back on stock.”
    “RetroArch [ERROR] :: [GL]: Stock GLSL shaders will be used.

    *I have also attached a pic for your reference (apologies for the shonty angle)

    Looking at the error I assumed there would be a config file which is still telling RetroArch to look at a non-existent directory for a shader I dont want to use. I just cannot find it anywhere.

    I did end up putting a shader directory including shaders into the “/home/pi/RetroPie/shader/hq2x.glsl” and this worked. However as mentioned this is not the shader I want to use. In fact I’m even fine with keeping the shader directory here if I could at least find where I can configure the reference to the shader used.

    Any help would be much appreciated, thanks.

    Floob
    Member
    Post count: 1629

    It looks like its just your paths that are wrong.

    Try this:

    borlandoflorida
    Participant
    Post count: 34

    I’m having the same issue as you – the paths are correct, but the shaders aren’t applying and I’m getting the same error messages.

    I’ve found this thread and I’m going to give it a go later.

    Floob
    Member
    Post count: 1629

    The thread you link to is from 2013, and fixed now – also the above issue is path related?

    The video above should work fine, but if you have any issues, let me know what error you get (ideally using 2.6.0) and it should be easy to fix.

    2 Shader videos are in my sig below.

    borlandoflorida
    Participant
    Post count: 34

    I compiled from source, so didn’t download the image. I’ve checked your vids, but can’t see any reference to the specific issue at hand…?

    Floob
    Member
    Post count: 1629

    Ah – I presume its caused by the source update making a path invalid.
    You could either use an image, or just amend the paths shown in your retroarch.cfg file.

    Floob
    Member
    Post count: 1629

    I tend to use the snes or phosphor based shaders, they seem to look good and dont affect the performance too much. I guess its a case of personal taste.
    I set mine in the /opt/retropie/configs/{systemname}/retroarch.cfg files.

    richardpi
    Participant
    Post count: 21

    Having my b+ running with hq4x_lcd3 at the moment. The looks are personal ofcours but this one looks pretty good on my 55″ I think, and doesn’t really slow down the b+(medium overclocking) too bad with both nes and snes emulation imho.

    Bit of a pity to read about the slowdowns; hoped to be able to get a 4 or 5xbrz plus some pretty scanlines on top of this on the RPi 2…

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.