Tagged: , , ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • bobbyt
    Participant
    Post count: 71

    I’m not sure how but I seemingly ‘broke’ F Keys while in emulators.

    Hitting F1 in a RetroArch based emulator does NOT bring up the RetroArch menu.

    I thought maybe the F Keys on my keyboard were dead, but I ruled this out as hitting F4 while in EmulationStation works as expected.

    I’ve tried going to into the RetorArch menu (using a controller toggle I setup) and re-assing the F Key based events, but after bringing up the menu telling me to hit a key pressing the F keys on the keyboard has no effect.

    I do notice a series of characters that become visible on the command line screen after exiting the emulator (while ES is still re-loading). They are: ^[[A
    I’m certain the F Keys are generating these as if I hit one F Key, then exit I see that combination of characters once. If I hit 10 F Keys (or one F Key 10 times) I see ten of them…

    ANY event that is tied to an F Key simply does not happen in RetroArch emulators… I didn’t make any config changes that could account for this (and tried rolling back the ones I did make), so I’m really not sure WHAT is going on…

    bobbyt
    Participant
    Post count: 71

    Unfortunately I believe I’ve ruled out a software based problem…

    I’ve restored an older backup of my card to try and fix the issue. The problem is, doing that has had NO effect on the issue.

    With the restore I have ruled out the following as causes:

    The keyboard: 2 separate brands, one wireless one wired both have the same issue. Using the keyboard on my primary computer confirms the F Keys are working normally.

    The Software: Restoring to a backup from 2 weeks ago, long before this problem started, didn’t fix the issue.

    The issue started after a couple of specific steps. I first accidentally hit one of the keys on the keyboard while in an emulator, which triggered ‘mute’. I tried to undo this by successively hitting each of the F Keys. I then exited out of the emulator & re-ran the same game/emulator combination. From that moment on none of the F Keys have worked…

    I’m now also noticing hitting the F Keys while in the command line outputs the following:

    F1: A
    F2: B
    F3: C
    F4: D
    F5: E
    F6 – F12: ~ (tilde)

    I’ve seen these same outputs being listed by others having F Key issues.

    Unless the letter outputs happens by default (which I can’t verify), it may be the key indication that the problem is occurring…

    bobbyt
    Participant
    Post count: 71

    Alright, this may be a general issue between the keyboard and RetroArch.

    Hiting space bar has no effect. Holding 1 has no effect.

    In short the only keys that work appear to be the arrow keys, return and escape…

    No idea why retroarch can no longer detect the majority of keyboard keys…

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.