Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • cacophony555
    Participant
    Post count: 126

    I’ve noticed that the aspect ratio seems way off for certain RetroArch cores in RetroPie. I started with the latest RetroPie SD image, and the default emulators for both NES and SNES both use RetroArch. They both display with an almost square aspect ratio. For NES it’s as if they’re blowing up the 256×240 resolution which is almost 1:1, instead of the filling a 4:3 region. SNES looks similar. In comparison, the other RetroPie defaults that utilize RetroArch cores (for PC Engine and Genesis) correctly display in a 4:3 aspect ratio.

    I tried the standalone PiSNES (optimized) binary as well and that also looked square. I saw that there was an option to force full screen display, but that’s not what I want. Interestingly the standalone binary for FCEUX does seem to display correctly in 4:3.

    Anyone else notice this or have suggestions on what I can do? The only option I’ve found was to force SNES to fullscreen and then change my TV to 4:3 mode, but that screws up other emulators as well as Emulation Station.

    Thanks!

    kitchuk
    Participant
    Post count: 207

    While in a retroarch emulator press F1 for the options. Here you can alter the ratio and scaling integer (you want it on). Also try setting your pi to a 4:3 aspect ratio.

    lolerzz
    Participant
    Post count: 27

    Same problem here, when I run rom and press f1 nothing happens.

    cacophony555
    Participant
    Post count: 126

    Yeah, F1 doesn’t do anything for me either. But I was able to fix it by modifying the retroarch.cfg file. You can either do this globablly for all retroarch cores or make a cfg specific to the core you want to change and then use the –appendconfig to include it (for examples of this see the es_systems.cfg file).

    The value I changed was the following:

    # A floating point value for video aspect ratio (width / height).
    # If this is not set, aspect ratio is assumed to be automatic.
    # Behavior then is defined by video_aspect_ratio_auto.
    # video_aspect_ratio =

    You can uncomment it and pick a value like 1.175, which looks pretty good to me. This value was taken from here: http://forums.nesdev.com/viewtopic.php?t=8063

    lolerzz
    Participant
    Post count: 27

    THANKS!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.