Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • bigbert
    Participant
    Post count: 7

    I got A really wierd problem that I just can’t solve. I have 2 controllers that was working properly. The problem now is that the number1 controller will stop woking almost everytime I reboot.

    in the /dev/input the js-file keeps switching between js0 and js1 so I have to reconfigure the retroarch.cfg everytime to get it to work again. So that is the problem. Don’t know have to solve this though.

    I have tried having the exakt same configuration for
    input_player1_joypad_index = “0” and
    input_player1_joypad_index = “1”
    That did not work…

    Anyone have any idea how to fix this wierdness?

    I should specify that this only happens in the emulators, not in the menu.

    hacha-dorada
    Participant
    Post count: 39

    How are you connecting the controllers to the Pi? Are you using some kind of hub? Have you tried connecting both joysticks in separate USB ports versus through the hub?

    bigbert
    Participant
    Post count: 7

    Thanks for the answer!
    No Im not using a hub. Im connecting the two controllers directly to the Pi. I have also tried switching controller ports with the same result.

    bigbert
    Participant
    Post count: 7

    Some new observations:

    if I remove all controllers there is still a js0-file in dev/input.

    If I connect my first usb snes controller, there will be two files, js0 and js1.

    If I connect the snes controller and the xbox controller I will still have 2 files, js0(or js1) and js2. Note. The xbox controller will always work(js2).

    Should I really have a js-file if I disconnect all the controllers? Maybe I could delete the js-file that is left when I have disconnected all the controllers? Or will that break everything?

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.