Viewing 1 post (of 1 total)
  • Author
    Posts
  • mikeveli20
    Participant
    Post count: 59

    Most PSX don’t use the analog. However, some do and even require it (Ape Escape). In order to get true analog for these games the following settings need to be configured:

    Core Options:
    Pad ‘n’ Type = analog

    Core Input Options:
    User ‘n’ Device Type = Retropad w/ Analog
    User ‘n’ Analog to Digital = None

    While this works great for games that use the analog, for those that don’t support it these settings (specifically Pad ‘n’ Type=analog) can cause the controller not to work at all.

    So the question is, is there any possible way to configure the “Pad ‘n’ Type” on a game by game basis?

    Edit: Made a bit of progress with this but still can’t change the setting I want. I’m able to change settings in the Core Input Options on a game by game basis by editing the config in the runcommand menu, but not Core Options. I looked in retroarch-core-options.cfg to see what the command was for pad type and it currently shows as pcsx_rearmed_pad1type = “analog”. So I tried adding pcsx_rearmed_pad1type = “standard” to the runcommand config of a game where the controller doesn’t work at all when set to analog. It didn’t change when I checked in game and the controller continued to not work unless I manually changed it to “standard” in the core options menu.

    I also tried adding #include “/opt/retropie/configs/all/retroarch-core-options.cfg” to the runcommand config to see if that would help but it made no difference.

Viewing 1 post (of 1 total)
  • The forum ‘Controller Configuration in RetroPie’ is closed to new topics and replies.