Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • johnbran
    Participant
    Post count: 3

    Alright, Ive looked everywhere for a solution but my emulator seems to get stuck on the screen that says “Sony Computer Entertainment Presents” and it wont ever get past it. I can still use my commands that I programed to get out of the emulator so I know its not that problem (maybe it is?).

    Im trying to run Legends of the Dragoon and Ive tried .iso files and now I have a .bin and .cue files but they get stuck at that screen. Can anyone help me out?

    davejaca
    Participant
    Post count: 42

    sounds like your BIOS is missing, see here: https://www.youtube.com/watch?v=r6-VOCyDoTc&t=21

    johnbran
    Participant
    Post count: 3

    The thing is that it recognizes the BIOS but I believe that this game in particular wont start with this emulator. I have gotten other PS games to work but this one.

    davejaca
    Participant
    Post count: 42

    Just tested, runs fine. Can make a vid of it running if you like?

    johnbran
    Participant
    Post count: 3

    What ROM’s and BIOS were you using. A video would be amazing but i can settle for screen shots.

    davejaca
    Participant
    Post count: 42

    No worries its quick and easy to make a vid, check it out below:
    BIOS as per the link in my first post up above. Hope you can get it running.

    neighbourhoodnerd
    Participant
    Post count: 111

    Pro tip for PSX: get a U.S BIOS and use only NTSC ROMs.

    Some PAL games had anti-piracy methods coded in. For example, the PAL versions of Speed Freaks and Spyro 2 will always crash after you play a few levels – by design.

    The NTSC editions don’t have this feature so they work great :)

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.