Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • dk999
    Participant
    Post count: 11

    Hi Guys!
    Trying to use the analog sticks of my 360 in some PSX Games that actually support it like Crash 3 or Ape Escape, but can’t find a hotkey or sth. to activate them. They were still recognised in other emulators, but the psx refuses to use them :-/
    Is there something I’m missing in my retroarch.cfg?

    input_player1_joypad_index = "0"
    input_player1_b_btn = "0"
    input_player1_y_btn = "2"
    input_player1_select_btn = "8"
    input_player1_start_btn = "9"
    input_player1_up_btn = "h0up"
    input_player1_down_btn = "h0down"
    input_player1_left_btn = "h0left"
    input_player1_right_btn = "h0right"
    input_player1_a_btn = "1"
    input_player1_x_btn = "3"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_btn = "6"
    input_player1_r2_btn = "7"
    input_player1_l3_btn = "11"
    input_player1_r3_btn = "12"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+2"
    input_player1_r_x_minus_axis = "-2"
    input_player1_r_y_plus_axis = "+3"
    input_player1_r_y_minus_axis = "-3"
    
    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "9"
    input_save_state_btn = "5"
    input_load_state_btn = "4"

    EDIT:
    Works now, for everyone having the same Isse:
    Add input_menu_toggle = F1 and input_hotkey_toggle = Esc to your retroarch.cfg.
    Now start a game, hold down Esc and press F1, now you should be in the menu. Go to Settings->Input and change Device Type to Joypad w/ analog and Analog D-Pad Mode to Left Stick ( if you want to play games with analog stick that doesn’t support it like older PSX-Games ). Assign some additional buttons if you like (i.e. for Disc change etc. ), go back to the main menu and save the config. It will be stored in a libretro.cfg in the retropie/configs/all/ folder. Just replace the retroarch.cfg with this one and everything should work now :)

    willshere112
    Participant
    Post count: 1

    Hi, how do I replace the retroarch.cfg file with the new libretro.cfg ? This has been bugging me for days now, I thought your solution had sorted it but as soon as I exit the game it goes back to the original retroarch config.

    pinion
    Participant
    Post count: 13

    I’m finding the same Wills. Create the libretro.cfg and paste it’s contents into retroarch.cfg and the settings don’t seem to hold. V3.0

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.