Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • newsworthy
    Participant
    Post count: 8

    Hello folks, just sharing a Eureka moment I had this week.

    Spent a whole week trying to run my PS3 controllers via USB into the Pi for RetroPie, but could never get them to work properly. They would be detected, work in jstest, even registered with the input config tool in ES (With errors, more on that later) but would never work properly within the ROMs themselves. This was also after following every guide I could I find on connecting PS3 controllers, which all concentrated on Bluetooth, not USB.

    After days of desperation, purchasing a powered USB hub (as I assumed it was a power issue) and manually editing many .cfg files, I found the culprit. It was my Wireless Keyboard, the Logitech K400.

    As soon as I unplugged the receiver to the hub, suddenly, success! They worked brilliantly.

    My only logical conclusion, is that the Pi could detect the controllers, but presumed that it’s commands would be coming in via the only wireless device it could find, being the keyboard, rather than being hard-wired.

    I now run two PS3 controllers with a wired keyboard, and have had nothing but joy.

    Just a heads up in case anyone else is having trouble. Good luck. :)

    newsworthy
    Participant
    Post count: 8

    Also, I still get the “Double tapping” problem with the ES input configuration tool within ES, but I found editing retroarch.cfg and es_input.cfg to match the controllers solved that after the fact.

    Run the input config tool first, to establish the template for the controller, then manually edit. I’ll post the values of my files later this evening.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.